diff mbox series

[bug#49915,2/3] gnu: go-github-com-mattn-go-shellwords: Fix sh path.

Message ID 291625dd0fc68e516af6d6707fe37ab6f8c86b6c.1628275842.git.iskarian@mgsn.dev
State New
Headers show
Series [bug#49915,1/3] gnu: go-github-com-mattn-go-shellwords: Update to 1.0.12. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen Aug. 6, 2021, 6:57 p.m. UTC
* gnu/packages/golang.scm (go-github-com-mattn-go-shellwords)[arguments]
<#:phases>{patch-sh-path}: New phase.
[inputs]: Add bash.
---
 gnu/packages/golang.scm | 25 ++++++++-----------------
 1 file changed, 8 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c32324f235..b46f9e9bbf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -58,6 +58,7 @@ 
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module ((gnu packages bootstrap) #:select (glibc-dynamic-linker))
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages glib)
@@ -5273,24 +5274,14 @@  systems.")
     (build-system go-build-system)
     (arguments
      `(#:import-path "github.com/mattn/go-shellwords"
-       ;; TODO: can't make homeless-shelter:
-       ;; go: disabling cache (/homeless-shelter/.cache/go-build) due to
-       ;; initialization failure: mkdir /homeless-shelter: permission denied
-
-       ;; This doesn't seem to work:
-
-       ;; #:phases
-       ;; (modify-phases %standard-phases
-       ;;   (replace 'check
-       ;;     (lambda* (#:key import-path #:allow-other-keys)
-       ;;       (setenv "HOME" "/tmp")
-       ;;       (invoke "go" "test" import-path))))
-
-       ;; TODO: There are also a couple of tests that have stymied Debian in
-       ;; the past.  They seem to work when run locally.
-
        #:tests? #f
-       ))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-sh-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "src/github.com/mattn/go-shellwords/util_posix.go"
+               (("/bin/sh") (which "sh"))))))))
+    (inputs `(("bash" ,bash)))
     (home-page "https://github.com/mattn/go-shellwords")
     (synopsis "Parse lines into shell words")
     (description "This package parses text into shell arguments.  Based on