diff mbox series

[bug#49915,1/3] gnu: go-github-com-mattn-go-shellwords: Update to 1.0.12.

Message ID 38f52b13a45c8e0792433861748499f1f5638cf7.1628275842.git.iskarian@mgsn.dev
State New
Headers show
Series [bug#49915,1/3] gnu: go-github-com-mattn-go-shellwords: Update to 1.0.12. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen Aug. 6, 2021, 6:55 p.m. UTC
* gnu/packages/golang.scm (go-github-com-mattn-go-shellwords): Update to 1.0.12.
---
Hello Guix,

I came across this package in my codebase travels; I've updated it and
re-enabled tests.

I verified that dependents go-github-com-junegunn-fzf@0.25.0 and ytfzf@1.2.0
build on x86-64.

--
Sarah
 gnu/packages/golang.scm | 71 ++++++++++++++++++++---------------------
 1 file changed, 34 insertions(+), 37 deletions(-)


base-commit: c8e2be3b32fe784a9db52d8a1a12902ab12ae7cb

Comments

Sharlatan Hellseher Feb. 15, 2024, 9:30 p.m. UTC | #1
Hi,

I've fixed patch apply failure, added one intermediate patch to fix
indentation and move the package to golang-xyz.

Pushed as 008811aef6..8c9bc0e710 to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 15f3ea46c4..c32324f235 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5257,48 +5257,45 @@  systems.")
       (license license:expat))))
 
 (define-public go-github-com-mattn-go-shellwords
-  (let ((commit "2444a32a19f450fabaa0bb3e96a703f15d9a97d2")
-        (version "1.0.5")
-        (revision "1"))
-    (package
-      (name "go-github-com-mattn-go-shellwords")
-      (version (git-version version revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/mattn/go-shellwords")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "08zcgr1az1n8zaxzwdd205j86hczgyc52nxfnw5avpw7rrkf7v0d"))))
-      (build-system go-build-system)
-      (arguments
-       `(#:import-path "github.com/mattn/go-shellwords"
-         ;; TODO: can't make homeless-shelter:
-         ;; go: disabling cache (/homeless-shelter/.cache/go-build) due to
-         ;; initialization failure: mkdir /homeless-shelter: permission denied
+  (package
+    (name "go-github-com-mattn-go-shellwords")
+    (version "1.0.12")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mattn/go-shellwords")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0l0l5s4hlsrm4z6hygig2pp1qirk5ycrzn9z27ay3yvg9k7zafzx"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/mattn/go-shellwords"
+       ;; TODO: can't make homeless-shelter:
+       ;; go: disabling cache (/homeless-shelter/.cache/go-build) due to
+       ;; initialization failure: mkdir /homeless-shelter: permission denied
 
-         ;; This doesn't seem to work:
+       ;; This doesn't seem to work:
 
-         ;; #:phases
-         ;; (modify-phases %standard-phases
-         ;;   (replace 'check
-         ;;     (lambda* (#:key import-path #:allow-other-keys)
-         ;;       (setenv "HOME" "/tmp")
-         ;;       (invoke "go" "test" import-path))))
+       ;; #:phases
+       ;; (modify-phases %standard-phases
+       ;;   (replace 'check
+       ;;     (lambda* (#:key import-path #:allow-other-keys)
+       ;;       (setenv "HOME" "/tmp")
+       ;;       (invoke "go" "test" import-path))))
 
-         ;; TODO: There are also a couple of tests that have stymied Debian in
-         ;; the past.  They seem to work when run locally.
+       ;; TODO: There are also a couple of tests that have stymied Debian in
+       ;; the past.  They seem to work when run locally.
 
-         #:tests? #f
-         ))
-      (home-page "https://github.com/mattn/go-shellwords")
-      (synopsis "Parse lines into shell words")
-      (description "This package parses text into shell arguments.  Based on
+       #:tests? #f
+       ))
+    (home-page "https://github.com/mattn/go-shellwords")
+    (synopsis "Parse lines into shell words")
+    (description "This package parses text into shell arguments.  Based on
 the @code{cpan} module @code{Parse::CommandLine}.")
-      (license license:expat))))
+    (license license:expat)))
 
 (define-public go-github-com-burntsushi-locker
   (let ((commit "a6e239ea1c69bff1cfdb20c4b73dadf52f784b6a")