diff mbox series

[bug#57368] gnu: Add python-plotext.

Message ID 28fb9ab00d5ee4e50c993b49915606a098d9c980.1661286389.git.peter@polidoro.io
State New
Headers show
Series [bug#57368] gnu: Add python-plotext. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro Aug. 23, 2022, 8:27 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-plotext): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Mathieu Othacehe Sept. 12, 2022, 7:03 p.m. UTC | #1
Hello,

> +    (version "5.0.2")

Sorry for the late review. It looks like the 5.2.2 is out there. Could
you please update it :)

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8b0aae76ac..8e00c9499d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -742,6 +742,31 @@  (define-public python-pymdown-extensions
 Markdown.  All extensions are found under the module namespace of pymdownx.")
     (license license:expat)))
 
+(define-public python-plotext
+  (package
+    (name "python-plotext")
+    (version "5.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "plotext" version))
+              (sha256
+               (base32
+                "1p28hdxgjhdrcwq795nqrglcp6v5cl936mbah31dqhgjk6cy5v71"))))
+    (build-system python-build-system)
+    ;; tests pass when run manually with test() function after install
+    ;; tests fail when run automatically during build with error:
+    ;; TypeError: don't know how to make test from: unix
+    (arguments
+     `(#:tests? #f))
+    (propagated-inputs (list python-pillow))
+    (home-page "https://github.com/piccolomo/plotext")
+    (synopsis "2D plotting library for Python to plot directly on a terminal")
+    (description
+     "Plotext is a Python 2D plotting library which produces
+figures directly on a terminal with syntax similar to matplotlib and can save
+plots as text or as colored html.")
+    (license license:expat)))
+
 (define-public python-mdx-gh-links
   (package
     (name "python-mdx-gh-links")