diff mbox series

[bug#62161,2/3] gnu: Add ruby-unicode-plot.

Message ID 27b987b3ea326da884b88b2dc210584da1fc2faa.1678715004.git.gemmaro.dev@gmail.com
State New
Headers show
Series Add youplot. | expand

Commit Message

gemmaro March 13, 2023, 1:53 p.m. UTC
* gnu/packages/plotutils.scm (ruby-unicode-plot): New variable.
---
 gnu/packages/plotutils.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 963587ca2e..34f507e825 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2016-2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -28,6 +29,7 @@  (define-module (gnu packages plotutils)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system ruby)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages bash)
@@ -50,7 +52,9 @@  (define-module (gnu packages plotutils)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages ruby)
   #:use-module (gnu packages qt)
+  #:use-module (gnu packages statistics)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tex)
   #:use-module (gnu packages web)
@@ -427,3 +431,28 @@  (define-public asymptote
     ;; noted otherwise, are released under version 3 (or later) of the GNU
     ;; Lesser General Public License"
     (license license:lgpl3+)))
+
+(define-public ruby-unicode-plot
+  (package
+    (name "ruby-unicode-plot")
+    (version "0.0.5")
+    ;; Source at RubyGems.org doesn't have test fixtures.
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url
+                     "https://github.com/red-data-tools/unicode_plot.rb")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0g67brnb7zp1xx9cp1x7bmyxwnvi2i8gplw7p1j7cppzin4kr1vj"))))
+    (build-system ruby-build-system)
+    (native-inputs (list bundler ruby-rake ruby-test-unit ruby-yard))
+    (propagated-inputs (list ruby-enumerable-statistics))
+    (synopsis "Library to plot your data by Unicode characters")
+    (description "UnicodePlot provides the feature to make charts with Unicode
+characters.  Supported charts are: barplot, boxplot, densityplot,
+histogram, lineplot, and scatterplot.")
+    (home-page "https://github.com/red-data-tools/unicode_plot.rb")
+    (license license:expat)))