diff mbox series

[bug#62161,3/3] gnu: Add youplot.

Message ID a9012126839e6944d6f07a73adfbbdd184c2a249.1678715004.git.gemmaro.dev@gmail.com
State New
Headers show
Series Add youplot. | expand

Commit Message

gemmaro March 13, 2023, 1:53 p.m. UTC
* gnu/packages/plotutils.scm (youplot): New variable.
---
 gnu/packages/plotutils.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 34f507e825..fdda6d4871 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -456,3 +456,29 @@  (define-public ruby-unicode-plot
 histogram, lineplot, and scatterplot.")
     (home-page "https://github.com/red-data-tools/unicode_plot.rb")
     (license license:expat)))
+
+(define-public youplot
+  (package
+    (name "youplot")
+    (version "0.4.5")
+    ;; Source at RubyGems.org doesn't have tests.
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/red-data-tools/YouPlot")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1y54apw7hx9mhjnf277w9wayvq954mdnip4dpajhc0qjg2464c2b"))))
+    (build-system ruby-build-system)
+    (native-inputs (list ruby-rake ruby-simplecov ruby-test-unit))
+    (propagated-inputs (list ruby-unicode-plot))
+    (synopsis "Command line tool that draw plots on the terminal")
+    (description
+     "YouPlot is a command line tool that draws plots on the terminal,
+powered by UnicodePlot gem.  It provides commands @command{youplot}
+and @command{uplot} (shorthand) are provided, and supports chart types
+of barplot, histogram, lineplot, scatter, density, boxplot, and count.")
+    (home-page "https://github.com/red-data-tools/YouPlot")
+    (license license:expat)))