diff mbox series

[bug#62916,core-updates,1/2] gnu: gcc: do not build gcov.

Message ID 234715f3c0fe265574fd9708abe0e057ee3c1641.1681770007.git.vivien@planete-kraus.eu
State New
Headers show
Series Try to fix p11-kit compilation to mingw | expand

Commit Message

Vivien Kraus April 17, 2023, 10:09 p.m. UTC
* gnu/packages/gcc.scm (gcc-configure-flags-for-triplet): Disable gcov when
targetting mingw.
---
 gnu/packages/gcc.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Ludovic Courtès April 25, 2023, 4:11 p.m. UTC | #1
Hi,

Vivien Kraus <vivien@planete-kraus.eu> skribis:

> * gnu/packages/gcc.scm (gcc-configure-flags-for-triplet): Disable gcov when
> targetting mingw.

Pushed this one as 74038cf66e3a8cdcd9d97a81d9176c3cdefdaaf7.

The p11-kit story isn’t good, but I’m not sure how to address it.  When
we find a way, we can add a feature branch to rebuild everything that
depends on it though.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 5b1ef83ce6..c6575bf9db 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -88,6 +88,10 @@  (define (gcc-configure-flags-for-triplet target)
              (string-prefix? "powerpc-" target))
          '("--with-long-double-128"))
 
+        ;; See https://bugs.gentoo.org/show_bug.cgi?id=843989
+        ((target-mingw? target)
+         '("--disable-gcov"))
+
         (else
          ;; TODO: Add `arm.*-gnueabi', etc.
          '())))