diff mbox series

[bug#62916,core-updates,2/2] NOT WORKING gnu: p11-kit: switch to meson-build-system.

Message ID 16c8a106c160315cef9c04287414e2788e8a87f2.1681770007.git.vivien@planete-kraus.eu
State New
Headers show
Series Try to fix p11-kit compilation to mingw | expand

Commit Message

Vivien Kraus April 17, 2023, 10:17 p.m. UTC
* gnu/packages/tls.scm (p11-kit): Switch to meson build system.
---
 gnu/packages/tls.scm | 19 ++++---------------
 1 file changed, 4 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index d41efe23b0..eaa18b9064 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -150,12 +150,9 @@  (define-public p11-kit
                            "download/" version "/p11-kit-" version ".tar.xz"))
        (sha256
         (base32 "1y5fm9gwhkh902r26p90qf1g2h1ziqrk4hgf9i9sxm2wzlz7ignq"))))
-    (build-system gnu-build-system)
+    (build-system meson-build-system)
     (native-inputs
-     (append (list pkg-config)
-             (if (hurd-target?)
-                 (list autoconf automake gettext-minimal libtool)
-                 '())))
+     (list pkg-config))
     (inputs
      (append (list libffi libtasn1)
              (if (hurd-target?)
@@ -165,7 +162,7 @@  (define-public p11-kit
      (list #:configure-flags
            ;; Use the default certificates so that users such as flatpak
            ;; find them.  See <https://issues.guix.gnu.org/49957>.
-           #~'("--with-trust-paths=/etc/ssl/certs/ca-certificates.crt")
+           #~'("-Dtrust_paths=/etc/ssl/certs/ca-certificates.crt")
            #:phases #~(modify-phases %standard-phases
                         #$@(if (hurd-target?)
                                #~((add-after 'unpack 'apply-hurd-patch
@@ -178,15 +175,7 @@  (define patch
                                   (replace 'bootstrap
                                     (lambda _
                                       (invoke "autoreconf" "-fiv"))))
-                               #~())
-                        (add-before 'check 'prepare-tests
-                          (lambda _
-                            ;; "test-runtime" expects XDG_RUNTIME_DIR to be set up
-                            ;; and looks for .cache and other directories (only).
-                            ;; For simplicity just drop it since it is irrelevant
-                            ;; in the build container.
-                            (substitute* "Makefile"
-                              (("test-runtime\\$\\(EXEEXT\\)") "")))))))
+                               #~()))))
     (home-page "https://p11-glue.github.io/p11-glue/p11-kit.html")
     (synopsis "PKCS#11 library")
     (description