diff mbox series

[bug#62553,core-updates,3/6] gnu: atk: Deprecate in favor of at-spi2-core.

Message ID 2036141189dd221b780af10a59888e27e0fe6dc7.1680212316.git.dev@jpoiret.xyz
State New
Headers show
Series Various fixes to packages | expand

Commit Message

Josselin Poiret March 30, 2023, 9:48 p.m. UTC
* gnu/packages/gtk.scm (atk): Deprecate.
---
 gnu/packages/gtk.scm | 38 +++-----------------------------------
 1 file changed, 3 insertions(+), 35 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 48e78146aa..93dad032cd 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -158,41 +158,6 @@  (define-public appmenu-gtk-module
     (home-page "https://gitlab.com/vala-panel-project/vala-panel-appmenu")
     (license (list license:lgpl3))))
 
-(define-public atk
-  (package
-    (name "atk")
-    (version "2.36.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnome/sources/" name "/"
-                                  (version-major+minor version)  "/"
-                                  name "-" version ".tar.xz"))
-              (sha256
-               (base32
-                "1217cmmykjgkkim0zr1lv5j13733m4w5vipmy4ivw0ll6rz28xpv"))))
-    (build-system meson-build-system)
-    (arguments
-     `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
-       ,@(if (%current-target-system)
-             `(#:configure-flags
-               ;; introspection requires running binaries for the host system
-               ;; on the build system.
-               '("-Dintrospection=false"))
-             '())))
-    (propagated-inputs (list glib)) ; required by atk.pc
-    (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("glib" ,glib "bin")             ; glib-mkenums, etc.
-       ("gobject-introspection" ,gobject-introspection) ; g-ir-compiler, etc.
-       ("pkg-config" ,pkg-config)))
-    (synopsis "GNOME accessibility toolkit")
-    (description
-     "ATK provides the set of accessibility interfaces that are implemented
-by other toolkits and applications.  Using the ATK interfaces, accessibility
-tools have full access to view and control running applications.")
-    (license license:lgpl2.1+)
-    (home-page "https://wiki.gnome.org/Accessibility")))
-
 (define-public cairo
   (package
     (name "cairo")
@@ -915,6 +880,9 @@  (define-public at-spi2-core-with-documentation
 (define-public at-spi2-atk
   (deprecated-package "at-spi2-atk" at-spi2-core))
 
+(define-public atk
+  (deprecated-package "atk" at-spi2-core))
+
 (define-public gtk+-2
   (package
     (name "gtk+")