mbox series

[bug#62553,core-updates,0/6] Various fixes to packages

Message ID cover.1680212316.git.dev@jpoiret.xyz
Headers show
Series Various fixes to packages | expand

Message

Josselin Poiret March 30, 2023, 9:44 p.m. UTC
Hi everyone,

Here are some odds and ends for core-updates.  The first three commits should
fix udiskie not building, and probably some other packages!  Before this patch,
atk in gtk would conflict with the atk included by at-spi2-core (the newer one),
and sometimes would get precedence.  This was because the merge of atk,
at-spi2-core and at-spi2-atk wasn't complete, only the last two were taken care
of.  One thing I'm unsure about is giving the newer at-spi2-core as an input to
gtk+-2, but it seemed to build fine.  Haven't tested it yet though.

The first gpgme patch lets its dependents build: flatpak wasn't able to pick it
up through pkg-config without, but now fails to build for another reason on my
end (something that's not reproducible unless you have less than 3% free
space!).  The second one is just clean-up, since we now have 1.18 as the main
version.

One of zsh's tests was failing because the deprecation warning of egrep was
being added to some output, I replaced only that one with grep -E, upstream has
a more comprehensive patch that only applies to HEAD.

Best,

Josselin Poiret (6):
  gnu: Replace all uses of atk by at-spi2-core.
  gnu: atkmm: Update to 2.36.2.
  gnu: atk: Deprecate in favor of at-spi2-core.
  gnu: gpgme: Propagate libassuan.
  gnu: Remove gpgme-1.18 and qgpgme-1.18.
  gnu: zsh: Patch failing test that uses egrep.

 gnu/local.mk                                  |  3 +-
 gnu/packages/animation.scm                    |  2 +-
 gnu/packages/chromium.scm                     |  1 -
 gnu/packages/crates-gtk.scm                   |  8 +--
 gnu/packages/gimp.scm                         |  2 +-
 gnu/packages/gnome.scm                        | 14 ++---
 gnu/packages/gnupg.scm                        | 29 +----------
 gnu/packages/graphviz.scm                     |  2 +-
 gnu/packages/gtk.scm                          | 51 ++++---------------
 gnu/packages/kde-pim.scm                      |  8 +--
 gnu/packages/mate.scm                         | 14 ++---
 gnu/packages/messaging.scm                    |  2 +-
 .../patches/zsh-egrep-failing-test.patch      | 11 ++++
 gnu/packages/qt.scm                           |  2 +-
 gnu/packages/rust-apps.scm                    |  2 +-
 gnu/packages/shells.scm                       |  3 +-
 gnu/packages/vim.scm                          |  2 +-
 gnu/packages/vnc.scm                          |  2 +-
 gnu/packages/web.scm                          |  2 +-
 19 files changed, 57 insertions(+), 103 deletions(-)
 create mode 100644 gnu/packages/patches/zsh-egrep-failing-test.patch


base-commit: cdba566261428d8949fcc4f7c7066a578e3009eb

Comments

Guillaume Le Vaillant March 31, 2023, 2:57 p.m. UTC | #1
Patches pushed as c000352c27f511dfb5569bef09f9b774d6100117 and
following.
Thanks.