[bug#75522,v0,3/4] gnu: Add zig-img.
Commit Message
zig-img is required by beanbag. However, there's no tags at the
moment, so we'll be using the commit mentioned in beanbag's repo.
* gnu/packages/zig-xyz.scm (zig-img): New variable.
Change-Id: If66231806ffa50d0e6ec3091ab50f454db100f21
---
gnu/packages/zig-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
@@ -340,6 +340,28 @@ (define-public zig-clap
"A simple and easy to use command line argument parser library for Zig.")
(license license:expat)))
+(define-public zig-img
+ (let ((commit "52f10dd3e3b1cd4614fe72a8a8f0eddc7700bc0a")
+ (revision "0"))
+ (package
+ (name "zig-img")
+ (version (git-version "0.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zigimg/zigimg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "187nh49rdv37arlvf056jiv58n4y87q2pm6qvznn75zrszjlvp0b"))))
+ (build-system zig-build-system)
+ (home-page "https://github.com/zigimg/zigimg")
+ (synopsis "Zig library for reading and writing different image formats")
+ (description
+ "This is a zig library for reading and writing different image formats.")
+ (license license:expat))))
+
(define-public zig-zls-0.10
(package
(name "zig-zls")