[bug#75522,v0,1/4] gnu: Add zig-clap.
Commit Message
* gnu/packages/zig-xyz.scm (zig-clap): New variable.
Change-Id: Ib438ffa083bd96102e4058d2c64dccecadff1aa5
---
gnu/packages/zig-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Comments
On Mon, 13 Jan 2025 02:19:00 +0800,
Ashvith Shetty wrote:
>
>[...]
> + (build-system zig-build-system)
> + (home-page "https://github.com/Hejsil/zig-clap")
> + (synopsis "Command line argument parsing library")
> + (description
> + "A simple and easy to use command line argument parser library for Zig.")
Please use a complete sentence.
> + (license license:expat)))
> +
> (define-public zig-zls-0.10
> (package
> (name "zig-zls")
> --
> 2.47.1
@@ -3,6 +3,7 @@
;;; Copyright © 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2024 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -301,6 +302,26 @@ (define-public zig-xkbcommon
(home-page "https://codeberg.org/ifreund/zig-xkbcommon")
(license license:expat)))
+(define-public zig-clap
+ (package
+ (name "zig-clap")
+ (version "0.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Hejsil/zig-clap")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xjskvyib3kai3nmp574zfm07yvjsbzsxfysj96ss9339nq07ix6"))))
+ (build-system zig-build-system)
+ (home-page "https://github.com/Hejsil/zig-clap")
+ (synopsis "Command line argument parsing library")
+ (description
+ "A simple and easy to use command line argument parser library for Zig.")
+ (license license:expat)))
+
(define-public zig-zls-0.10
(package
(name "zig-zls")