[bug#75499,3/3] gnu: make-librewolf-source: Take l10n package as an arg.

Message ID 20250111172936.3737-3-ian@retrospec.tv
State New
Headers
Series gnu: librewolf: Update to 133.0.3-1. |

Commit Message

Ian Eure Jan. 11, 2025, 5:29 p.m. UTC
  * gnu/packages/librewolf.scm (make-librewolf-source): Take l10n package as an
arg.

Change-Id: I3c405edc07edb54e27afee16325c93a83d37ad79
---
 gnu/packages/librewolf.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
  

Patch

diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 1d58191e0c..a4eb45f03e 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -21,7 +21,7 @@ 
 ;;; Copyright © 2021, 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2023 Tomas Volf <wolf@wolfsden.cz>
-;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
+;;; Copyright © 2023, 2024, 2025 Ian Eure <ian@retrospec.tv>
 ;;; Copyright © 2024 Remco van 't Veer <remco@remworks.net>
 ;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
 ;;;
@@ -126,7 +126,7 @@  (define firefox-l10n
       (file-name (git-file-name "firefox-l10n" commit))
       (sha256 (base32 "0g778fnxg5mkqm3rgryzl64f3n4pczngjdlby07vh2dycvmlyga8")))))
 
-(define* (make-librewolf-source #:key version firefox-hash librewolf-hash)
+(define* (make-librewolf-source #:key version firefox-hash librewolf-hash l10n)
   (let* ((ff-src (firefox-source-origin
                   (car (string-split version #\-))
                   firefox-hash))
@@ -182,7 +182,7 @@  (define* (make-librewolf-source #:key version firefox-hash librewolf-hash)
                  (substitute* "scripts/librewolf-patches.py"
                    (("l10n_dir = Path(\"..\", \"l10n\")")
                     (string-append
-                     "l10n_dir = \"" #+firefox-l10n "\""))))
+                     "l10n_dir = \"" #+l10n "\""))))
 
                ;; Run the build script
                (invoke "make" "all")
@@ -213,7 +213,8 @@  (define-public librewolf
      (make-librewolf-source
       #:version version
       #:firefox-hash "06ya18ma1gndci0aygz75hidn3kwa1kji78g8smh7fq0091aad7i"
-      #:librewolf-hash "05mlqqcvsa84h3nagm51hwsxkxsbcn2676fj4bih37ddlgkylf3b"))
+      #:librewolf-hash "05mlqqcvsa84h3nagm51hwsxkxsbcn2676fj4bih37ddlgkylf3b"
+      #:l10n firefox-l10n))
     (build-system gnu-build-system)
     (arguments
      (list