[bug#75499,2/3] gnu: librewolf: Update to 133.0.3-1.

Message ID 20250111172936.3737-2-ian@retrospec.tv
State New
Headers
Series gnu: librewolf: Update to 133.0.3-1. |

Commit Message

Ian Eure Jan. 11, 2025, 5:29 p.m. UTC
  Upstream bugfix release.  There were no 133.0.1 or .2 Firefox releases,
133.0.3 follows 133.0.  This is straightforward update, other than switching
from gzip to pigz, which is a LibreWolf upstream change.

* gnu/packages/librewolf.scm (librewolf): Update to 133.0.3-1.

Change-Id: I40d305f16bd5a7b55f0d40a3e8885abd2cf2de0a
---
 gnu/packages/librewolf.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
  

Patch

diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 2011e261e4..1d58191e0c 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -154,7 +154,7 @@  (define* (make-librewolf-source #:key version firefox-hash librewolf-hash)
                       #+(canonical-package xz)
                       #+(canonical-package sed)
                       #+(canonical-package grep)
-                      #+(canonical-package gzip)
+                      #+(canonical-package pigz)
                       #+(canonical-package tar)))
                (set-path-environment-variable
                 "PYTHONPATH"
@@ -203,17 +203,17 @@  (define rust-librewolf rust) ; 1.75 is the default in Guix, 1.65 is the minimum.
 ;; Update this id with every update to its release date.
 ;; It's used for cache validation and therefore can lead to strange bugs.
 ;; ex: date '+%Y%m%d%H%M%S'
-(define %librewolf-build-id "20241130102406")
+(define %librewolf-build-id "20241215105141")
 
 (define-public librewolf
   (package
     (name "librewolf")
-    (version "133.0-1")
+    (version "133.0.3-1")
     (source
      (make-librewolf-source
       #:version version
-      #:firefox-hash "0q6cqfnwc2x09frdvsndmhck8ixrnbl281j9rqw5w8bd7fd2qas9"
-      #:librewolf-hash "1xf7gx3xm3c7dhch9gwpb0xp11lcyim1nrbm8sjljxdcs7iq9jy4"))
+      #:firefox-hash "06ya18ma1gndci0aygz75hidn3kwa1kji78g8smh7fq0091aad7i"
+      #:librewolf-hash "05mlqqcvsa84h3nagm51hwsxkxsbcn2676fj4bih37ddlgkylf3b"))
     (build-system gnu-build-system)
     (arguments
      (list