[bug#74517,v4,06/10] gnu: libde265: Remove unused qtbase-5 input.

Message ID 20250107223336.4083-6-ngraves@ngraves.fr
State New
Headers
Series [bug#74517,v4,01/10] gnu: Add v4l-utils-minimal. |

Commit Message

Nicolas Graves Jan. 7, 2025, 10:33 p.m. UTC
  * gnu/packages/video.scm (libde265)
[native-inputs]: Improve style.
[inputs]: Improve style.  Remove qtbase-5 which wasn't actually
used (need more inputs to build graphical tools).
---
 gnu/packages/video.scm | 13 ++++---------
 1 file changed, 4 insertions(+), 9 deletions(-)
  

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 37d0bbb52b..72c89cc851 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -711,16 +711,11 @@  (define-public libde265
      `(#:configure-flags
        (list "--disable-static")))
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python-wrapper)))
+     (list autoconf automake libtool pkg-config python-wrapper))
     (inputs
-     `(;; XXX: Build fails with libvideogfx.
-       ;; ("libvideogfx" ,libvideogfx)
-       ("qt" ,qtbase-5)
-       ("sdl" ,sdl)))
+     ;; XXX: Build a complete version using libswscale or libvideogfx
+     ;; and qtbase-5.
+     (list sdl))
     (synopsis "H.265 video codec implementation")
     (description "Libde265 is an implementation of the h.265 video codec.  It is
 written from scratch and has a plain C API to enable a simple integration into