[bug#74517,v4,02/10] gnu: zbar: Improve style.

Message ID 20250107223336.4083-2-ngraves@ngraves.fr
State New
Headers
Series [bug#74517,v4,01/10] gnu: Add v4l-utils-minimal. |

Commit Message

Nicolas Graves Jan. 7, 2025, 10:33 p.m. UTC
  * gnu/packages/aidc.scm (zbar)[native-inputs, inputs]: Improve style.
---
 gnu/packages/aidc.scm | 30 +++++++++++++++---------------
 1 file changed, 15 insertions(+), 15 deletions(-)
  

Patch

diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index bc9c47a480..0c1f26495b 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -194,22 +194,22 @@  (define-public zbar
                                               (assoc-ref %outputs "out")
                                               "/etc"))))
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("gettext" ,gettext-minimal)
-       ("glib" ,glib "bin")
-       ("gobject-introspection" ,gobject-introspection)
-       ("libtool" ,libtool)
-       ("pkg-config" ,pkg-config)
-       ("python-wrapper" ,python-wrapper)))
+     (list autoconf
+           automake
+           gettext-minimal
+           `(,glib "bin")
+           gobject-introspection
+           libtool
+           patchelf
+           pkg-config
+           python-wrapper))
     (inputs
-     `(("dbus" ,dbus)
-       ("imagemagick" ,imagemagick)
-       ("libjpeg" ,libjpeg-turbo)
-       ("perl" ,perl)
-       ("python" ,python)
-       ("qtx11extras" ,qtx11extras)
-       ("v4l-utils" ,v4l-utils)))
+     (list dbus
+           imagemagick
+           libjpeg-turbo
+           perl
+           python
+           v4l-utils))
     (propagated-inputs
      ;; These are in 'requires' field of .pc files.
      (list glib gtk+ qtbase-5))