[bug#75159,v2,1/3] gnu: Add trompeloeil.
Commit Message
From: Ashvith Shetty <ashvith@noreply.codeberg.org>
* gnu/packages/check.scm (trompeloeil): New variable.
Change-Id: I442cd0b5e84e8f9956b16b7d9235f67d9f5f693e
---
gnu/packages/check.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
@@ -52,6 +52,7 @@
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3806,6 +3807,36 @@ (define-public toml-test
tests. The output format is JSON.")
(license license:expat)))
+(define-public trompeloeil
+ (package
+ (name "trompeloeil")
+ (version "49")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rollbear/trompeloeil")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0m4bfzcj033qfk3sihbikrhk9krsdbsqk79nsambnsnqqcgc2903"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list "-D TROMPELOEIL_BUILD_TESTS=yes")
+ #:test-target "test/self_test"
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? test-target #:allow-other-keys)
+ (when tests?
+ (invoke test-target)))))))
+ (native-inputs (list catch2-3))
+ (home-page "https://github.com/rollbear/trompeloeil")
+ (synopsis "Header only C++14 mocking framework")
+ (description
+ "Trompeloeil is a thread-safe header-only mocking framework for C++11/14.")
+ (license license:boost1.0)))
+
(define-public unittest-cpp
(package
(name "unittest-cpp")