diff mbox series

[bug#73523,1/3,0/3] gnu: add python-pywlroots

Message ID 20240928063520.24064-1-bigbookofbug@proton.me
State New
Headers show
Series gnu: add pywlroots | expand

Commit Message

bigbookofbug--- via Guix-patches via Sept. 28, 2024, 6:35 a.m. UTC
From: big bug <bigbookofbug@proton.me>

---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 22351e813a..83f645a038 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -155,6 +155,7 @@ 
 ;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
 ;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
 ;;; Copyright © 2024 Peter Kannewitz <petre-vps@posteo.net>
+;;; Copyright © 2024 big bug <bigbookofbug@proton.me>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -11023,6 +11024,28 @@  (define-public python-pywal
 your favourite programs.")
     (license license:expat)))
 
+(define-public python-pywayland
+  (package
+    (name "python-pywayland")
+    (version "0.4.18")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pywayland" version))
+       (sha256
+	(base32 "0cv5aqn23id31mn95q6isn5vcnjcd4dvaqzn52ihbb9sg01dx2jr"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:tests? #f))
+    (inputs (list wayland))
+    (propagated-inputs (list python-cffi))
+    (native-inputs (list python-pytest pkg-config))
+    (home-page "https://github.com/flacjacket/pywayland/")
+    (synopsis "Python bindings for the libwayland librar")
+    (description "PyWayland provides a wrapper to the libwayland library using the CFFI library to provide access to the Wayland library calls and written in pure Python.")
+    (license license:asl2.0)))
+
 (define-public python-click-didyoumean
   (package
     (name "python-click-didyoumean")