diff mbox series

[bug#44518,v2,08/25] gnu: Add ghc-mattermost-api.

Message ID 20240709140812.6183-9-romain.garbage@inria.fr
State New
Headers show
Series Add matterhorn package. | expand

Commit Message

Romain GARBAGE July 9, 2024, 1:53 p.m. UTC
* gnu/packages/haskell-web.scm (ghc-mattermost-api): New variable.

Change-Id: Idc2a8fb0d8589b38d7e50aa7565fff71dcc6ab28
---
 gnu/packages/haskell-web.scm | 42 ++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 08b2136cb2..8021cbaefc 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -843,6 +843,48 @@  (define-public ghc-css-text
 Haskell.")
     (license license:bsd-3)))
 
+(define-public ghc-mattermost-api
+  (package
+    (name "ghc-mattermost-api")
+    (version "90000.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "mattermost-api" version))
+       (sha256
+        (base32 "1ka3r4bnfwlbjnkws8vkg8i9gj8wzsyss137p7hxrx4sr75s6iyv"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "mattermost-api")))
+    (inputs (list ghc-websockets
+                  ghc-aeson
+                  ghc-crypton-connection
+                  ghc-memory
+                  ghc-resource-pool
+                  ghc-http
+                  ghc-http-media
+                  ghc-network-uri
+                  ghc-modern-uri
+                  ghc-unordered-containers
+                  ghc-hashable
+                  ghc-gitrev
+                  ghc-microlens
+                  ghc-microlens-th
+                  ghc-pretty-show
+                  ghc-split
+                  ghc-connection))
+    (native-inputs (list ghc-tasty ghc-tasty-hunit ghc-hunit))
+    (arguments
+     (list
+      #:tests? #f)) ;tests fail: unable to setup network socket
+    (home-page "http://hackage.haskell.org/package/mattermost-api")
+    (synopsis "Client API for Mattermost chat system")
+    (description
+     "Client API for Mattermost chat system.  Mattermost is a flexible, open source
+messaging platform that meets even the most demanding privacy and security
+standards.  This library provides network API interaction with the Mattermost
+server.")
+    (license license:bsd-3)))
+
 (define-public ghc-mime-types
   (package
     (name "ghc-mime-types")