diff mbox series

[bug#44518,v2,13/25] gnu: Add ghc-checkers.

Message ID 20240709140812.6183-14-romain.garbage@inria.fr
State New
Headers show
Series Add matterhorn package. | expand

Commit Message

Romain GARBAGE July 9, 2024, 1:53 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-checkers): New variable.

Change-Id: I4228398238a169e49e68ead60cbe69ef0437e3e9
---
 gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 60d25dd4bf..e29e84aa9b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -1830,6 +1830,31 @@  (define-public ghc-cheapskate
 cross-site scripting (@dfn{XSS}) attacks.")
     (license license:bsd-3)))
 
+(define-public ghc-checkers
+  (package
+    (name "ghc-checkers")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "checkers" version))
+       (sha256
+        (base32 "1r4rsa4k0fy8xig3m530ryflry9viv9v47g4gh7h0ld27rbd6z60"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "checkers")))
+    (inputs (list ghc-random ghc-quickcheck ghc-semigroupoids))
+    (arguments
+     `(#:cabal-revision ("1"
+                         "0wkvf57zd7i87z18vj285whjpcl9pscpwxz2cp7v7w6kk0769p0i")))
+    (home-page "https://github.com/haskell-checkers/checkers")
+    (synopsis "Check properties on standard classes and data structures")
+    (description
+     "Checkers wraps up the expected properties associated with various standard type
+classes as @code{QuickCheck} properties.  Also some morphism properties.  It
+also provides arbitrary instances and generator combinators for common data
+types. . © 2008-2013 by Conal Elliott; BSD3 license.")
+    (license license:bsd-3)))
+
 (define-public ghc-chell
   (package
     (name "ghc-chell")