diff mbox series

[bug#71037,2/3] gnu: python-pydevd: Update to 2.9.6.

Message ID 20240518124316.19861-2-ngraves@ngraves.fr
State New
Headers show
Series gnu: python-pydevd: Update to 2.9.6. | expand

Commit Message

Nicolas Graves May 18, 2024, 12:43 p.m. UTC
* gnu/packages/python-xyz.scm (python-pydevd): Update to 2.9.6.
  [arguments]<#:test-flags>: Adapt value.

Change-Id: I55cc8129fb78f0ee54519f45b31746a54881d84e
---
 gnu/packages/python-xyz.scm | 22 ++++++++--------------
 1 file changed, 8 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c2039273429..fb12aba967f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16694,19 +16694,17 @@  (define-public python-file
 libmagic.")))
 
 (define-public python-pydevd
-  ;; Use the latest commit, which includes cleanups that removes Python 2
-  ;; syntax that would fail to build.
-  (let ((revision "0")
-        (commit "47e298499ef19563bb2ef5941a57046a35ae6868"))
     (package
       (name "python-pydevd")
-      (version (git-version "2.8.0" revision commit))
+      (version "2.9.6")
       (source
        (origin
          (method git-fetch)
          (uri (git-reference
                (url "https://github.com/fabioz/PyDev.Debugger")
-               (commit commit)))
+               (commit (string-append
+                        "pydev_debugger_"
+                        (string-join (string-split version #\.) "_")))))
          (modules '((guix build utils)))
          (snippet '(begin
                      ;; Delete pre-built binaries.
@@ -16716,7 +16714,7 @@  (define-public python-pydevd
          (file-name (git-file-name name version))
          (sha256
           (base32
-           "1yd017dh6xgxrqcyf8kk8jrr0a3zw895yfjih0z5jghyf0rck38q"))))
+           "1niqb6l3m03arfjh14k9k5i5bi56m8qmc3pyi1qkbvqqp5bkydac"))))
       (build-system pyproject-build-system)
       (arguments
        (list
@@ -16728,18 +16726,14 @@  (define-public python-pydevd
                  ;; Python 3.10:
                  ;; <https://github.com/fabioz/PyDev.Debugger/issues/222>.
                  "not test_set_pydevd_break_01 "
-                 ;; This one fails for unknown reasons.
-                 "and not test_completion_sockets_and_messages "
                  ;; the GUI event loop requires an X server.
                  "and not test_gui_event_loop_custom "
                  ;; This test validates that 'pydevd' is not in the
                  ;; exception message, but it is due to being part
                  ;; of the build file name present in the message.
                  "and not test_evaluate_exception_trace "
-                 ;; These fail on systems with YAMA LSM’s ptrace
-                 ;; scope > 0. Upstream issue:
-                 ;; https://github.com/fabioz/PyDev.Debugger/issues/218
-                 "and not test_attach_to_pid"))
+                 ;; This test fail with TimeoutError, no message on stderr.
+                 "and not test_soft_terminate "))
         #:phases
         #~(modify-phases %standard-phases
             (add-after 'unpack 'fix-tests
@@ -16802,7 +16796,7 @@  (define-public python-pydevd
       (synopsis "Python debugger")
       (description "PyDev.Debugger is a capable Python debugger used in PyDev
 and other @acronym{IDEs, Integrated Development Environments}.")
-      (license license:epl1.0))))
+      (license license:epl1.0)))
 
 (define-public python-debugpy
   (package