diff mbox series

[bug#71037,1/3] gnu: python-pydevd: Move to pyproject-build-system.

Message ID 20240518124316.19861-1-ngraves@ngraves.fr
State New
Headers show
Series gnu: python-pydevd: Update to 2.9.6. | expand

Commit Message

Nicolas Graves May 18, 2024, 12:43 p.m. UTC
* gnu/packages/python-xyz.scm (python-pydevd):
  [build-system]: Move to pyproject-build-system.
  [arguments]: Replace 'check phase by 'pre-check phase and
  <#:test-flags>.

Change-Id: I8227ac8b1b6031c30c6d09480cacaa3347df21a7
---
 gnu/packages/python-xyz.scm | 46 ++++++++++++++++++-------------------
 1 file changed, 23 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8151355a418..c2039273429 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16717,9 +16717,29 @@  (define-public python-pydevd
          (sha256
           (base32
            "1yd017dh6xgxrqcyf8kk8jrr0a3zw895yfjih0z5jghyf0rck38q"))))
-      (build-system python-build-system)
+      (build-system pyproject-build-system)
       (arguments
        (list
+        #:test-flags
+        #~(list "-n" (number->string (parallel-job-count))
+                "-k"
+                (string-append
+                 ;; The two "break_01" tests have been failing on
+                 ;; Python 3.10:
+                 ;; <https://github.com/fabioz/PyDev.Debugger/issues/222>.
+                 "not test_set_pydevd_break_01 "
+                 ;; This one fails for unknown reasons.
+                 "and not test_completion_sockets_and_messages "
+                 ;; the GUI event loop requires an X server.
+                 "and not test_gui_event_loop_custom "
+                 ;; This test validates that 'pydevd' is not in the
+                 ;; exception message, but it is due to being part
+                 ;; of the build file name present in the message.
+                 "and not test_evaluate_exception_trace "
+                 ;; These fail on systems with YAMA LSM’s ptrace
+                 ;; scope > 0. Upstream issue:
+                 ;; https://github.com/fabioz/PyDev.Debugger/issues/218
+                 "and not test_attach_to_pid"))
         #:phases
         #~(modify-phases %standard-phases
             (add-after 'unpack 'fix-tests
@@ -16758,30 +16778,10 @@  (define-public python-pydevd
                 (invoke #+(cxx-for-target) "-shared" "-o" "attach.so"
                         "-fPIC" "-nostartfiles"
                         "pydevd_attach_to_process/linux_and_mac/attach.cpp")))
-            (replace 'check
+            (add-before 'check 'pre-check
               (lambda* (#:key tests? #:allow-other-keys)
                 (when tests?
-                  (setenv "PYDEVD_USE_CYTHON" "YES")
-                  (invoke "pytest" "-vv"
-                          "-n" (number->string (parallel-job-count))
-                          "-k"
-                          (string-append
-                           ;; The two "break_01" tests have been failing on
-                           ;; Python 3.10:
-                           ;; <https://github.com/fabioz/PyDev.Debugger/issues/222>.
-                           "not test_set_pydevd_break_01 "
-                           ;; This one fails for unknown reasons.
-                           "and not test_completion_sockets_and_messages "
-                           ;; the GUI event loop requires an X server.
-                           "and not test_gui_event_loop_custom "
-                           ;; This test validates that 'pydevd' is not in the
-                           ;; exception message, but it is due to being part
-                           ;; of the build file name present in the message.
-                           "and not test_evaluate_exception_trace "
-                           ;; These fail on systems with YAMA LSM’s ptrace
-                           ;; scope > 0. Upstream issue:
-                           ;; https://github.com/fabioz/PyDev.Debugger/issues/218
-                           "and not test_attach_to_pid")))))
+                  (setenv "PYDEVD_USE_CYTHON" "YES"))))
             (add-after 'install 'install-attach-binary
               (lambda _
                 (install-file "attach.so"