diff mbox series

[bug#69980,v2,08/14] gnu: python-cfgv: Update to 3.4.0.

Message ID 20240509144944.30385-9-ngraves@ngraves.fr
State New
Headers show
Series Update and cleanup pre-commit & friends. | expand

Commit Message

Nicolas Graves May 9, 2024, 2:47 p.m. UTC
From: Vinicius Monego <monego@posteo.net>

* gnu/packages/python-xyz.scm (python-cfgv): Update to 3.4.0.
[build-system]: Use pyproject-build-system.
[arguments]: Do not override the check phase.

Change-Id: Id666a57e4d619697ffa272893930f1c94d5c283e
---
 gnu/packages/python-xyz.scm | 13 +++----------
 1 file changed, 3 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1c93236c8b0..714e44b916d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27935,7 +27935,7 @@  (define-public python-dns-lexicon
 (define-public python-cfgv
   (package
     (name "python-cfgv")
-    (version "3.3.1")
+    (version "3.4.0")
     (source
      (origin
        ;; There are no tests in the PyPI tarball.
@@ -27945,15 +27945,8 @@  (define-public python-cfgv
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1pci97cmn3v45sfch9s3lshidrl0309ls9byidic0l8drkwnkwcj"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest" "-vv")))))))
+        (base32 "0g7jg6dssyax6k85lk8afs8qdzgq138g6ij0jmmhgdv5fzks6k9z"))))
+    (build-system pyproject-build-system)
     (native-inputs
      (list python-pytest))
     (home-page "https://github.com/asottile/cfgv")