diff mbox series

[bug#70158,v2,3/3] gnu: scilab: Improve package management robustness in scilab-cli.

Message ID 20240410071517.30074-3-ngraves@ngraves.fr
State New
Headers show
Series [bug#70158,v2,1/3] gnu: scilab: Cleanup. | expand

Commit Message

Nicolas Graves April 10, 2024, 7:15 a.m. UTC
* gnu/packages/maths.scm (scilab)[source]<origin>: Improve
  package management robustness in scilab-cli by allowing
  tbx_build_help to log the scilab mode incompatibility error and not
  process the rest of the function instead of failing with it.
* gnu/packages/patches/scilab-tbx_build_help.patch :
  Add patch.
* gnu/local.mk(dist_patch_DATA): Add
  gnu/packages/patches/scilab-tbx_build_help.patch.

Change-Id: I8ee94afb4aba906cbc8c7ca67f4c89aa0cf55ae6
---
 gnu/local.mk                                  |  1 +
 gnu/packages/maths.scm                        |  3 +-
 .../patches/scilab-tbx_build_help.patch       | 38 +++++++++++++++++++
 3 files changed, 41 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/scilab-tbx_build_help.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index f8f4fd40d5..f373fa016c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2048,6 +2048,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/scalapack-gcc-10-compilation.patch	\
   %D%/packages/patches/scheme48-tests.patch			\
   %D%/packages/patches/scilab-better-compiler-detection.patch	\
+  %D%/packages/patches/scilab-tbx_build_help.patch		\
   %D%/packages/patches/scons-test-environment.patch		\
   %D%/packages/patches/screen-hurd-path-max.patch		\
   %D%/packages/patches/scsh-nonstring-search-path.patch	\
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0b6d8596eb..0d5382629d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9715,7 +9715,8 @@  (define-public scilab
        (sha256
         (base32
          "08nyfli3x7gd396ffd1a8zn9fj3gm6a8yw0ggm547c09sp2rgvl7"))
-       (patches (search-patches "scilab-better-compiler-detection.patch"))
+       (patches (search-patches "scilab-better-compiler-detection.patch"
+                                "scilab-tbx_build_help.patch"))
        (modules '((guix build utils)
                   (ice-9 ftw)))
        (snippet
diff --git a/gnu/packages/patches/scilab-tbx_build_help.patch b/gnu/packages/patches/scilab-tbx_build_help.patch
new file mode 100644
index 0000000000..d2a9b41357
--- /dev/null
+++ b/gnu/packages/patches/scilab-tbx_build_help.patch
@@ -0,0 +1,38 @@ 
+From c59d78c5a5c8c187450f157cf7f8480455e8e6a2 Mon Sep 17 00:00:00 2001
+From: Nicolas Graves <ngraves@ngraves.fr>
+Date: Wed, 3 Apr 2024 03:32:23 +0200
+Subject: [PATCH] scilab: tbx_build_help: Allow for some flexibility under
+ -nwni.
+
+upstream reference: https://gitlab.com/scilab/scilab/-/merge_requests/818
+
+---
+ .../modules_manager/macros/tbx_build_help.sci        | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/scilab/modules/modules_manager/macros/tbx_build_help.sci b/scilab/modules/modules_manager/macros/tbx_build_help.sci
+index 7862e33a868..5593ee3dc04 100644
+--- a/scilab/modules/modules_manager/macros/tbx_build_help.sci
++++ b/scilab/modules/modules_manager/macros/tbx_build_help.sci
+@@ -58,12 +58,12 @@ function tbx_build_help(moduletitle, path)
+ 
+     // Check scilab mode
+     if and(getscilabmode() <> ["STD" "NW"]) then
+-        error(msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode()));
++        msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode());
++    else
++        directory_language = basename(path);
++        default_language = "en_US"
++
++        xmltojar(path, moduletitle, directory_language, default_language);
+     end
+ 
+-    directory_language = basename(path);
+-    default_language = "en_US"
+-
+-    xmltojar(path, moduletitle, directory_language, default_language);
+-
+ endfunction
+-- 
+2.41.0
+