diff mbox series

[bug#70158,v2,1/3] gnu: scilab: Cleanup.

Message ID 20240410071517.30074-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#70158,v2,1/3] gnu: scilab: Cleanup. | expand

Commit Message

Nicolas Graves April 10, 2024, 7:15 a.m. UTC
* gnu/packages/maths.scm (scilab):
  [arguments]<#:phases>: In pre-build phase, remove unecessary
  code, due to the former introduction of the rewrap-scilab-cli
  phase. More robust version setting in the set-version phase. It
  anticipates for the next release which will not use "main" anymore.
  [source]<origin>(snippet) Sort dynamic_link deleted files.
  [inputs]: Add bash-minimal.

Change-Id: I49b17886405e1ed8161e71b51655fa393ff7f10b
---
 gnu/packages/maths.scm | 13 ++++---------
 1 file changed, 4 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 03760f3f3e..00b3ed213b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9759,9 +9759,9 @@  (define-public scilab
                "compile"
                "config.guess"
                "config.sub"
-               "ltmain.sh"
                "depcomp"
                "install-sh"
+               "ltmain.sh"
                "missing"))
             (delete-file-recursively "modules/dynamic_link/src/scripts/m4")
             (for-each delete-file
@@ -9785,6 +9785,7 @@  (define-public scilab
     (inputs (list `(,pcre "bin")
                   `(,pcre "out")
                   arpack-ng
+                  bash-minimal
                   curl
                   fftw
                   gettext-minimal
@@ -9842,10 +9843,8 @@  (define-public scilab
             (add-after 'unpack 'set-version
               (lambda _
                 (substitute* "modules/core/includes/version.h.in"
-                  (("scilab-branch-main")  ; version
-                   (string-append
-                    "scilab-"
-                    #$(version-major+minor (package-version this-package)))))))
+                  (("branch-[a-z0-9\\.]*")  ; version
+                   #$(version-major+minor (package-version this-package))))))
             (add-after 'unpack 'restrain-to-scilab-cli
               (lambda _
                 ;; Install only scilab-cli.desktop
@@ -9879,10 +9878,6 @@  (define-public scilab
                   ((assoc-ref %standard-phases 'bootstrap)))))
             (add-before 'build 'pre-build
               (lambda* (#:key inputs #:allow-other-keys)
-                ;; Fix scilab script.
-                (substitute* "bin/scilab"
-                  (("/bin/ls")
-                   (search-input-file inputs "bin/ls")))
                 ;; Fix core.start.
                 (substitute* "modules/core/etc/core.start"
                   (("'SCI/modules")