diff mbox series

[bug#69231,4/6] gnu: node-serialport-parser-cctalk: Move in alphabetical order.

Message ID 20240219001112.29393-4-ngraves@ngraves.fr
State New
Headers show
Series [bug#69231,1/6] gnu: node-serialport: Move package in alphabetical order. | expand

Commit Message

Nicolas Graves Feb. 19, 2024, 12:11 a.m. UTC
* gnu/packages/node-xyz.scm (node-serialport-parser-cctalk): Move
package in alphabetical order.

Change-Id: Ia849d7f2a02f2d7ba8117e031056e01239a3a5fb
---
 gnu/packages/node-xyz.scm | 46 +++++++++++++++++++--------------------
 1 file changed, 23 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 4960d7f54c..1891caabf7 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1269,6 +1269,29 @@  (define-public node-serialport-parser-byte-length
 messages.  This package provides @code{ByteLength}, a parser that emits data
 as a buffer every time a specified number of bytes are received.")))
 
+(define-public node-serialport-parser-cctalk
+  (package
+    (inherit node-serialport)
+    (name "node-serialport-parser-cctalk")
+    (version "9.2.4")
+    (inputs `())
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda args
+             (chdir "packages/parser-cctalk"))))
+       #:tests? #f))
+    (synopsis "Node SerialPort parser for the ccTalk protocol")
+    (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports.  The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages.  This package provides @code{CCTalk}, which emits packets for the
+ccTalk protocol (an open standard for currency detectors) as they are
+received.")))
+
 (define-public node-serialport-parser-delimiter
   (package
     (inherit node-serialport)
@@ -1381,29 +1404,6 @@  (define-public node-serialport-parser-inter-byte-timeout
 messages.  This package provides @code{InterByteTimeout}, a parser that emits
 data if there is a pause between packets for the specified amount of time.")))
 
-(define-public node-serialport-parser-cctalk
-  (package
-    (inherit node-serialport)
-    (name "node-serialport-parser-cctalk")
-    (version "9.2.4")
-    (inputs `())
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'chdir
-           (lambda args
-             (chdir "packages/parser-cctalk"))))
-       #:tests? #f))
-    (synopsis "Node SerialPort parser for the ccTalk protocol")
-    (description "Node SerialPort is a modular suite of Node.js packages for
-accessing serial ports.  The Guix package @code{node-serialport} provides the
-recommended high-level interface.
-
-Parsers are used to take raw binary data and transform them into usable
-messages.  This package provides @code{CCTalk}, which emits packets for the
-ccTalk protocol (an open standard for currency detectors) as they are
-received.")))
-
 (define-public node-serialport-stream
   (package
     (inherit node-serialport)