diff mbox series

[bug#69231,3/6] gnu: node-serialport-parser-byte-length: Move in alphabetical order.

Message ID 20240219001112.29393-3-ngraves@ngraves.fr
State New
Headers show
Series [bug#69231,1/6] gnu: node-serialport: Move package in alphabetical order. | expand

Commit Message

Nicolas Graves Feb. 19, 2024, 12:11 a.m. UTC
* gnu/packages/node-xyz.scm (node-serialport-parser-byte-length): Move
package in alphabetical order.

Change-Id: I0b6126f11695c9e08fb51327a7a87385928d4472
---
 gnu/packages/node-xyz.scm | 44 +++++++++++++++++++--------------------
 1 file changed, 22 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index bb1fb826ed..4960d7f54c 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1247,6 +1247,28 @@  (define-public node-serialport-bindings
 directly.  There is also a @code{MockBinding} available (but not yet packaged
 for Guix) to assist with testing.")))
 
+(define-public node-serialport-parser-byte-length
+  (package
+    (inherit node-serialport)
+    (name "node-serialport-parser-byte-length")
+    (version "9.2.4")
+    (inputs `())
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda args
+             (chdir "packages/parser-byte-length"))))
+       #:tests? #f))
+    (synopsis "Node SerialPort parser for fixed-length buffers")
+    (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports.  The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages.  This package provides @code{ByteLength}, a parser that emits data
+as a buffer every time a specified number of bytes are received.")))
+
 (define-public node-serialport-parser-delimiter
   (package
     (inherit node-serialport)
@@ -1382,28 +1404,6 @@  (define-public node-serialport-parser-cctalk
 ccTalk protocol (an open standard for currency detectors) as they are
 received.")))
 
-(define-public node-serialport-parser-byte-length
-  (package
-    (inherit node-serialport)
-    (name "node-serialport-parser-byte-length")
-    (version "9.2.4")
-    (inputs `())
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'chdir
-           (lambda args
-             (chdir "packages/parser-byte-length"))))
-       #:tests? #f))
-    (synopsis "Node SerialPort parser for fixed-length buffers")
-    (description "Node SerialPort is a modular suite of Node.js packages for
-accessing serial ports.  The Guix package @code{node-serialport} provides the
-recommended high-level interface.
-
-Parsers are used to take raw binary data and transform them into usable
-messages.  This package provides @code{ByteLength}, a parser that emits data
-as a buffer every time a specified number of bytes are received.")))
-
 (define-public node-serialport-stream
   (package
     (inherit node-serialport)