diff mbox series

[bug#68791,3/3] gnu: Add nextpnr-ecp5.

Message ID 20240129150356.GA84024@flux.utah.edu
State New
Headers show
Series Patch series to add/update nextpnr-ecp5 + deps | expand

Commit Message

Gary Wong Jan. 29, 2024, 3:03 p.m. UTC
* gnu/packages/fpga.scm (nextpnr-ecp5): New variable.

Change-Id: Iec50903140fc9f0458423adbbe333e189e601922
---
 gnu/packages/fpga.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index b42a3503..3dcd981e 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -652,3 +652,29 @@  (define-public trellis
 for bitstream creation.")
     (license (list license:isc license:expat))
     (home-page "https://github.com/YosysHQ/prjtrellis")))
+
+(define-public nextpnr-ecp5
+  (package
+    (name "nextpnr-ecp5")
+    (version "0.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/YosysHQ/nextpnr")
+             (commit (string-append "nextpnr-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "146nc05ypsyjnxdpayc4g6d16f5igry46nydrb13niix51q11030"))))
+    (inputs (list boost eigen python trellis))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags `("-DARCH=ecp5" ,(string-append
+                                           "-DTRELLIS_INSTALL_PREFIX="
+                                           (assoc-ref %build-inputs "trellis")))
+       #:tests? #f)) ;contains no test target
+    (synopsis "Portable FPGA place and route tool")
+    (description "Nextpnr aims to be a vendor neutral, timing driven,
+FOSS FPGA place and route tool.")
+    (home-page "https://github.com/YosysHQ/nextpnr")
+    (license license:isc)))