diff mbox series

[bug#68763,v2,3/7] gnu: Add go-staticcheck.

Message ID 20240127182134.6393-3-ngraves@ngraves.fr
State New
Headers show
Series [bug#68763,v2,1/7] gnu: Remove go-github-com-kisielk-gotool. | expand

Commit Message

Nicolas Graves Jan. 27, 2024, 6:21 p.m. UTC
* gnu/packages/golang-check.scm (go-staticcheck): New variable.

Change-Id: I82ce27df1bdbd79ae4740928e0661b585289d02b
---
 gnu/packages/golang-check.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 6de21c7b5a..66114050f3 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -94,6 +94,21 @@  (define-public go-keyify
     (description "This package turns unkeyed struct literals (@code{T{1, 2,
 3}}) into keyed ones (@code{T{A: 1, B: 2, C: 3}}) in Go.")))
 
+(define-public go-staticcheck
+  (package
+    (inherit go-honnef-co-go-tools)
+    (name "go-staticcheck")
+    (arguments
+     `(#:go ,go-1.18
+       #:import-path "honnef.co/go/tools/cmd/staticcheck"
+       #:unpack-path "honnef.co/go/tools"
+       #:install-source? #f))
+    (synopsis "Staticcheck advanced Go linter")
+    (description
+     "Staticcheck is a state of the art linter for the Go programming language.
+Using static analysis, it finds bugs and performance issues, offers
+simplifications, and enforces style rules.")))
+
 (define-public go-github-com-alecthomas-assert
   (let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
         (revision "1"))