diff mbox series

[bug#68763,v2,2/7] gnu: Add go-keyify.

Message ID 20240127182134.6393-2-ngraves@ngraves.fr
State New
Headers show
Series [bug#68763,v2,1/7] gnu: Remove go-github-com-kisielk-gotool. | expand

Commit Message

Nicolas Graves Jan. 27, 2024, 6:21 p.m. UTC
* gnu/packages/golang-check.scm (go-keyify): New variable.

Change-Id: I99d41a18cb0e00dd35bef9c2c8fce12748f24ad4
---
 gnu/packages/golang-check.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index b8944b367e..6de21c7b5a 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -82,6 +82,18 @@  (define-public go-honnef-co-go-tools
 simplifications, and enforces style rules.")
     (license license:expat)))
 
+(define-public go-keyify
+  (package
+    (inherit go-honnef-co-go-tools)
+    (name "go-keyify")
+    (arguments
+     `(#:import-path "honnef.co/go/tools/cmd/keyify"
+       #:unpack-path "honnef.co/go/tools"
+       #:install-source? #f))
+    (synopsis "Transform an unkeyed struct literal into a keyed one in Go.")
+    (description "This package turns unkeyed struct literals (@code{T{1, 2,
+3}}) into keyed ones (@code{T{A: 1, B: 2, C: 3}}) in Go.")))
+
 (define-public go-github-com-alecthomas-assert
   (let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
         (revision "1"))