diff mbox series

[bug#66886,v4,3/6] gnu: python-rich: Update to 13.7.0.

Message ID 20240114235938.24529-3-goodoldpaul@autistici.org
State New
Headers show
Series [bug#66886,v4,1/6] gnu: Add python-pygments-2.16. | expand

Commit Message

Giacomo Leidi Jan. 14, 2024, 11:59 p.m. UTC
* gnu/packages/bioinformatics.scm (multiqc)[propagated-inputs]: Use
python-rich-12.4.

* gnu/packages/python-xyz.scm (python-rich): Update to 13.7.0;
[source]: switch to git-origin to have tests;
[build-system]: switch to pyproject-build-system;
[arguments]: remove it since this boilerplate is now handled by the
pyproject-build-system;
[propagated-inputs]: remove python-colorama as it's not listed on
pyproject.toml;
replace python-commonmark with python-markdown-it-py;
use python-pygments-2.16;
move python-attrs from here...;
[native-inputs]: ...to here;
drop "tests" input;
add python-pytest-cov;
[home-page]: https://github.com/willmcgugan/rich now redirects to
https://github.com/Textualize/rich ;
(python-rich-12.4): new variable;
(pelican)[propagated-inputs]: use python-pygments-2.16.

* gnu/packages/python-web.scm (httpie)[propagated-inputs]: Use
python-pygments-2.16.

Change-Id: I16ea6f27d24f84d86db659c224705c81fac3b42e
---
 gnu/packages/bioinformatics.scm |  2 +-
 gnu/packages/python-web.scm     |  2 +-
 gnu/packages/python-xyz.scm     | 64 ++++++++++++++++-----------------
 3 files changed, 33 insertions(+), 35 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f75254ed9f..60d0dc6f8f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12512,7 +12512,7 @@  (define-public multiqc
            python-numpy
            python-pyyaml
            python-requests
-           python-rich
+           python-rich-12.4
            python-rich-click
            python-simplejson
            python-spectra))
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 567b01f396..74ec405a94 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1208,7 +1208,7 @@  (define-public httpie
      '(#:tests? #f))
     (propagated-inputs
      (list python-colorama
-           python-pygments
+           python-pygments-2.16
            python-requests
            python-requests-toolbelt
            python-pysocks
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a0ad12a29f..cef458e0fc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7205,7 +7205,7 @@  (define-public pelican
            python-feedgenerator
            python-jinja2
            python-markdown
-           python-pygments
+           python-pygments-2.16
            python-pytz
            python-rich
            python-unidecode))
@@ -18585,49 +18585,47 @@  (define-public python-slugid
 (define-public python-rich
   (package
     (name "python-rich")
-    (version "12.4.1")
+    (version "13.7.0")
     (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "rich" version))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Textualize/rich")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "149vjb4cpf9mz14iig0b6d8065dm8aslp6pc45g9ipmp1wf00ffj"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs tests? #:allow-other-keys)
-             (when tests?
-               (copy-recursively (string-append
-                                  (assoc-ref inputs "tests") "/tests")
-                                 "tests")
-               (invoke "python" "-m" "pytest" "-vv")))))))
+                "0qyhw2vvk17qdmfrmi45z4dd0fkwx3l2qrf3iy0yc2y7pfgrmg9g"))))
+    (build-system pyproject-build-system)
     (propagated-inputs
-     (list python-attrs python-colorama python-commonmark python-pygments
-           python-typing-extensions))
+     (list python-markdown-it-py python-pygments-2.16 python-typing-extensions))
     (native-inputs
-     `(("python-pytest" ,python-pytest)
-       ("tests"
-        ;; The release on pypi comes without tests.  We can't build from this
-        ;; checkout, though, because installation requires an invocation of
-        ;; poetry.
-        ,(origin
-           (method git-fetch)
-           (uri (git-reference
-                 (url "https://github.com/willmcgugan/rich")
-                 (commit (string-append "v" version))))
-           (file-name (git-file-name name version))
-           (sha256
-            (base32
-             "17c3gljn8zv32xnpsgd3fqgqn4r7cdfqri41hridcpbhssdgkyp9"))))))
-    (home-page "https://github.com/willmcgugan/rich")
+     (list poetry python-attr python-pytest python-pytest-cov))
+    (home-page "https://github.com/Textualize/rich")
     (synopsis "Render rich text and more to the terminal")
     (description
      "This is a Python package for rendering rich text, tables, progress bars,
 syntax highlighting, markdown and more to the terminal.")
     (license license:expat)))
 
+(define-public python-rich-12.4
+  (package
+    (inherit python-rich)
+    (version "12.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Textualize/rich")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name "python-rich" version))
+              (sha256
+               (base32
+                "17c3gljn8zv32xnpsgd3fqgqn4r7cdfqri41hridcpbhssdgkyp9"))))
+    (propagated-inputs
+     (list python-colorama
+           python-commonmark
+           python-pygments
+           python-typing-extensions))))
+
 (define-public python-rich-click
   (package
     (name "python-rich-click")