diff mbox series

[bug#66886,v4,1/6] gnu: Add python-pygments-2.16.

Message ID 20240114235938.24529-1-goodoldpaul@autistici.org
State New
Headers show
Series [bug#66886,v4,1/6] gnu: Add python-pygments-2.16. | expand

Commit Message

Giacomo Leidi Jan. 14, 2024, 11:59 p.m. UTC
This patch has also been sent to the python-team branch with bug #66884.

* gnu/packages/python-xyz.scm (python-pygments-2.16): New variable.

Change-Id: I863fc1aaea9930991b6f92643befbde7ba1a335c
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: bcc9cd1aaeb53c323b199623de4fafe8594d1a95
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 37d7dd0dd5..5f159c39d1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6202,6 +6202,27 @@  (define-public python-pygments
      "Pygments is a syntax highlighting package written in Python.")
     (license license:bsd-2)))
 
+(define-public python-pygments-2.16
+  (package
+    (inherit python-pygments)
+    (version "2.16.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Pygments" version))
+       (sha256
+        (base32
+         "0abfx7n0mgpxk05f2kini3p78wsp1yi7lh0yjk49pii0914z1bqx"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      ;; Some tests require sphinx, which depends on this, so we only run
+      ;; basic tests.
+      '(list "--ignore-glob=tests/*/*")))
+    (native-inputs
+     (list python-pytest))))
+
 (define-public python-pygments-github-lexers
   (package
     (name "python-pygments-github-lexers")