diff mbox series

[bug#66735,core-updates,2/2] gnu: python-graph-tool: Update to 2.58.

Message ID 20231024193404.249783-2-code@greghogan.com
State New
Headers show
Series Update boost. | expand

Commit Message

Greg Hogan Oct. 24, 2023, 7:33 p.m. UTC
* gnu/packages/graph.scm (python-graph-tool): Update to 2.58.
[source](patches): Fix for Boost 1.83 compatibility.
* gnu/packages/patches/python-graph-tool-boost-fix.patch: New file.
* gnu/local.mk: Add it.
---
 gnu/local.mk                                     |  1 +
 gnu/packages/graph.scm                           |  5 +++--
 .../patches/python-graph-tool-boost-fix.patch    | 16 ++++++++++++++++
 3 files changed, 20 insertions(+), 2 deletions(-)
 create mode 100644 gnu/packages/patches/python-graph-tool-boost-fix.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index b4d588fdc6..ae8af63557 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1752,6 +1752,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/python-chai-drop-python2.patch		\
   %D%/packages/patches/python-docrepr-fix-tests.patch		\
   %D%/packages/patches/python-feedparser-missing-import.patch	\
+  %D%/packages/patches/python-graph-tool-boost-fix.patch	\
   %D%/packages/patches/python-louvain-fix-test.patch		\
   %D%/packages/patches/python-random2-getrandbits-test.patch		\
   %D%/packages/patches/python-poppler-qt5-fix-build.patch	\
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 881033047d..9ba5f5bc53 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -631,15 +631,16 @@  (define-public mscgen
 (define-public python-graph-tool
   (package
     (name "python-graph-tool")
-    (version "2.57")
+    (version "2.58")
     (source (origin
               (method url-fetch)
               (uri (string-append
                     "https://downloads.skewed.de/graph-tool/graph-tool-"
                     version ".tar.bz2"))
+              (patches (search-patches "python-graph-tool-boost-fix.patch"))
               (sha256
                (base32
-                "0wmvzx509lvigja6cfxh45r4b7wns64vmik0x4rz4y4fnxrhw2m2"))))
+                "05vsk2600wn790hk7gr2f0609bzcslyhhv9x157n43vxy4y6r8vj"))))
     (build-system gnu-build-system)
     (arguments
      `(#:imported-modules (,@%gnu-build-system-modules
diff --git a/gnu/packages/patches/python-graph-tool-boost-fix.patch b/gnu/packages/patches/python-graph-tool-boost-fix.patch
new file mode 100644
index 0000000000..19ece783ee
--- /dev/null
+++ b/gnu/packages/patches/python-graph-tool-boost-fix.patch
@@ -0,0 +1,16 @@ 
+https://git.skewed.de/count0/graph-tool/-/commit/0a837b40538df619f43706d50efe0c7afde755a9.diff
+
+Scheduled for inclusion in next release after version 2.58.
+
+diff --git a/src/graph/gml.hh b/src/graph/gml.hh
+index 7bea0ca362305a1eba7bfba69813064363809ea0..62027809dab5885f47da3a01fbf3fcf057b8e02e 100644
+--- a/src/graph/gml.hh
++++ b/src/graph/gml.hh
+@@ -25,6 +25,7 @@
+ #include <boost/variant/recursive_variant.hpp>
+ #include <boost/variant/get.hpp>
+ #include <boost/spirit/include/support_istream_iterator.hpp>
++#include <boost/regex/v5/unicode_iterator.hpp>
+ 
+ #include <boost/algorithm/string/replace.hpp>
+