diff mbox series

[bug#66735,core-updates,1/2] gnu: boost: Update to 1.83.0.

Message ID 20231024193404.249783-1-code@greghogan.com
State New
Headers show
Series Update boost. | expand

Commit Message

Greg Hogan Oct. 24, 2023, 7:33 p.m. UTC
* gnu/packages/boost.scm (boost): Update to 1.83.0.
[source](patches): Add new and remove old upstream patches.
(patch-flags): Strip prefix to match source directory structure.
---
 gnu/packages/boost.scm | 31 +++++--------------------------
 1 file changed, 5 insertions(+), 26 deletions(-)

Comments

Maxim Cournoyer Jan. 20, 2024, 7:18 p.m. UTC | #1
Hi,

Greg Hogan <code@greghogan.com> writes:

> * gnu/packages/boost.scm (boost): Update to 1.83.0.
> [source](patches): Add new and remove old upstream patches.
> (patch-flags): Strip prefix to match source directory structure.

Applied.  The second patch was already applied.
diff mbox series

Patch

diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 98dccf7f16..27ec6d9e32 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -66,7 +66,7 @@  (define (boost-patch name version hash)
 (define-public boost
   (package
     (name "boost")
-    (version "1.80.0")
+    (version "1.83.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
@@ -74,33 +74,12 @@  (define-public boost
                                   (version-with-underscores version) ".tar.bz2"))
               (patches
                (list (boost-patch
-                      ;; Boost.Filesystem directory iterators may fail to
-                      ;; construct for a network share on Windows prior to 10:
-                      ;; https://github.com/boostorg/filesystem/pull/246,
-                      ;; https://github.com/boostorg/filesystem/issues/245
-                      "0001-filesystem-win-fix-dir-it-net-share.patch" version
-                      "067hhylqkzzdbqzc1hkbpaqmvz248lxqrdhb2yi6iq9qabsik3lk")
-                     (boost-patch
-                      ;; In Boost.Filesystem on Windows, weakly_canonical fails
-                      ;; to process paths that start with the "\\?\" prefix:
-                      ;; https://github.com/boostorg/filesystem/issues/247
-                      "0002-filesystem-fix-weakly-canonical-long-paths.patch" version
-                      "00w3albf8527glclx85p5b2ml3vr06xpwwmfyzg005v1cp8avcpi")
-                     (boost-patch
-                      ;; Boost.Unordered containers are not in a valid state
-                      ;; after moving:
-                      ;; https://github.com/boostorg/unordered/issues/139
-                      "0003-unordered-valid-after-move.patch" version
-                      "0dw839w22cawqawfpsx7j7v9y0x2vn66m732iidpxvdxbjn2kzva")
-                     (boost-patch
-                      ;; Fixed a missing include on POSIX systems that don't
-                      ;; support *at APIs:
-                      ;; https://github.com/boostorg/filesystem/issues/250
-                      "0004-filesystem-posix-fix-no-at-apis-missing-include.patch" version
-                      "09k8k3b1306jkjls12wfghj820n828j6aaxzmcr0wpnjhp8fzi1v")))
+                      "0001-unordered-fix-copy-assign.patch" version
+                      "09j61m5xh7099k5na9i43x5rra51znf7vm2nyh89yqpizcll9q66")))
+              (patch-flags '("-p2"))
               (sha256
                (base32
-                "1h00qp4z5k6lfz310xjwsmqs8fwxi6ngas51169cafz4h9fmc68y"))))
+                "13iviiwk1srpw9dmiwabkxv56v0pl0zggjp8zxy1419k5zzfsy34"))))
     (build-system gnu-build-system)
     (inputs
      (append