diff mbox series

[bug#66104,7/9] gnu: rust-parking-lot-core-0.9 update to version 0.9.8

Message ID 20231003085639.146661-8-arnav.jose@gmail.com
State New
Headers show
Series [bug#66104,1/9] gnu: add rust-dashmap-5 | expand

Commit Message

Andrew Jose Oct. 3, 2023, 8:56 a.m. UTC
changelog:
cargo-inputs: remove rust-windows-sys-0.45
              add rust-windows-targets-0.48
---
 gnu/packages/crates-io.scm | 21 +++++++++++----------
 1 file changed, 11 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e64b70a8b8..c2d4273152 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45260,14 +45260,15 @@  (define-public rust-parking-lot-0.7
 (define-public rust-parking-lot-core-0.9
   (package
     (name "rust-parking-lot-core")
-    (version "0.9.7")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "parking_lot_core" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "08cm5gg3a4jmr683x9dgih8vj66yn772kjvc8y1m0flyz6wwnsch"))))
+    (version "0.9.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "parking_lot_core" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0ixlak319bpzldq20yvyfqk0y1vi736zxbw101jvzjp7by30rw4k"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
@@ -45278,12 +45279,12 @@  (define-public rust-parking-lot-core-0.9
         ("rust-redox-syscall" ,rust-redox-syscall-0.2)
         ("rust-smallvec" ,rust-smallvec-1)
         ("rust-thread-id" ,rust-thread-id-4)
-        ("rust-windows-sys" ,rust-windows-sys-0.45))))
+        ("rust-windows-targets" ,rust-windows-targets-0.48))))
     (home-page "https://github.com/Amanieu/parking_lot")
     (synopsis "API for creating custom synchronization primitives")
     (description "This package provides an advanced API for creating custom
 synchronization primitives.")
-    (license (list license:expat license:asl2.0))))
+    (license (list license:asl2.0 license:expat))))
 
 (define-public rust-parking-lot-core-0.8
   (package