diff mbox series

[bug#66104,2/9] gnu: add rust-filedescriptor-0.8

Message ID 20231003085639.146661-3-arnav.jose@gmail.com
State New
Headers show
Series [bug#66104,1/9] gnu: add rust-dashmap-5 | expand

Commit Message

Andrew Jose Oct. 3, 2023, 8:56 a.m. UTC
---
 gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9f598aad01..b8e5cc8322 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24218,6 +24218,29 @@  (define-public rust-file-diff-1
     (description "An atomic utility for diffing files in testing.")
     (license license:bsd-3)))
 
+(define-public rust-filedescriptor-0.8
+  (package
+    (name "rust-filedescriptor")
+    (version "0.8.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "filedescriptor" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0vplyh0cw35kzq7smmp2ablq0zsknk5rkvvrywqsqfrchmjxk6bi"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-libc" ,rust-libc-0.2)
+	("rust-thiserror" ,rust-thiserror-1)
+	("rust-winapi" ,rust-winapi-0.3))))
+    (home-page "https://github.com/wez/wezterm")
+    (synopsis "More ergonomic wrappers around RawFd and RawHandle")
+    (description
+     "The purpose of this crate is to make it a bit more ergonomic for portable applications that need to work with the platform level @code{RawFd} and @code{RawHandle} types.  Rather than conditionally using @code{RawFd} and @code{RawHandle,} the @code{FileDescriptor} type can be used to manage ownership, duplicate, read and write.")
+    (license license:expat)))
+
 (define-public rust-filesize-0.2
   (package
     (name "rust-filesize")