diff mbox series

[bug#66134,07/12] gnu: add rust-dotenvy-0.15

Message ID 20230921124458.580438-7-arnav.jose@gmail.com
State New
Headers show
Series Add just | expand

Commit Message

Andrew Jose Sept. 21, 2023, 12:44 p.m. UTC
---
 gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7be551e89d..57e03dad70 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20966,6 +20966,28 @@  (define-public rust-dotenv-0.10
         ("rust-regex" ,rust-regex-0.2)
         ("rust-syn" ,rust-syn-0.11))))))
 
+(define-public rust-dotenvy-0.15
+  (package
+    (name "rust-dotenvy")
+    (version "0.15.7")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "dotenvy" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "16s3n973n5aqym02692i1npb079n5mb0fwql42ikmwn8wnrrbbqs"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-clap" ,rust-clap-3))
+       #:cargo-development-inputs (("rust-once-cell" ,rust-once-cell-1)
+                                   ("rust-tempfile" ,rust-tempfile-3))))
+    (home-page "https://github.com/allan2/dotenvy")
+    (synopsis "A well-maintained fork of the dotenv crate")
+    (description
+     "This package provides a well-maintained fork of the dotenv crate")
+    (license license:expat)))
+
 (define-public rust-draw-state-0.8
   (package
     (name "rust-draw-state")