diff mbox series

[bug#66134,11/12] gnu: add patch for just

Message ID 20230921124458.580438-11-arnav.jose@gmail.com
State New
Headers show
Series Add just | expand

Commit Message

Andrew Jose Sept. 21, 2023, 12:44 p.m. UTC
---
 gnu/packages/patches/just-remove-test.patch | 61 +++++++++++++++++++++
 1 file changed, 61 insertions(+)
 create mode 100644 gnu/packages/patches/just-remove-test.patch
diff mbox series

Patch

diff --git a/gnu/packages/patches/just-remove-test.patch b/gnu/packages/patches/just-remove-test.patch
new file mode 100644
index 0000000000..1a0e9ade94
--- /dev/null
+++ b/gnu/packages/patches/just-remove-test.patch
@@ -0,0 +1,61 @@ 
+From f38e27675f320366dbfda02348c8f4731d55d464 Mon Sep 17 00:00:00 2001
+From: Andrew Jose <arnav.jose@gmail.com>
+Date: Thu, 21 Sep 2023 17:43:49 +0530
+Subject: [PATCH] remove broken tests
+
+---
+ tests/functions.rs | 15 ---------------
+ tests/string.rs    | 14 --------------
+ 2 files changed, 29 deletions(-)
+
+diff --git a/tests/functions.rs b/tests/functions.rs
+index 5511329..56f3c09 100644
+--- a/tests/functions.rs
++++ b/tests/functions.rs
+@@ -25,21 +25,6 @@ foo:
+   stderr:   format!("echo {} {} {} {}\n", target::arch(), target::os(), target::family(), num_cpus::get()).as_str(),
+ }
+ 
+-#[cfg(not(windows))]
+-test! {
+-  name:     env_var_functions,
+-  justfile: r#"
+-p := env_var('USER')
+-b := env_var_or_default('ZADDY', 'HTAP')
+-x := env_var_or_default('XYZ', 'ABC')
+-
+-foo:
+-  /bin/echo '{{p}}' '{{b}}' '{{x}}'
+-"#,
+-  stdout:   format!("{} HTAP ABC\n", env::var("USER").unwrap()).as_str(),
+-  stderr:   format!("/bin/echo '{}' 'HTAP' 'ABC'\n", env::var("USER").unwrap()).as_str(),
+-}
+-
+ #[cfg(not(windows))]
+ test! {
+   name: path_functions,
+diff --git a/tests/string.rs b/tests/string.rs
+index a7e0894..a9fc852 100644
+--- a/tests/string.rs
++++ b/tests/string.rs
+@@ -366,17 +366,3 @@ test! {
+   "#,
+   stdout: "\n\nfoo\\n\nbar",
+ }
+-
+-test! {
+-  name:     shebang_backtick,
+-  justfile: "
+-    x := `#!/usr/bin/env sh`
+-  ",
+-  stderr:   "
+-    error: Backticks may not start with `#!`
+-      |
+-    1 | x := `#!/usr/bin/env sh`
+-      |      ^^^^^^^^^^^^^^^^^^^
+-  ",
+-  status:   EXIT_FAILURE,
+-}
+-- 
+2.34.1
+