diff mbox series

[bug#64305,4/4] gnu: uwufetch: Add supported-systems.

Message ID 20230626171407.23641-4-juli@incana.org
State New
Headers show
Series Fixup uwufetch. | expand

Commit Message

Juliana Sims June 26, 2023, 5:14 p.m. UTC
* gnu/packages/admin.scm (uwufetch): Add supported-systems.
---
 gnu/packages/admin.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Juliana Sims July 27, 2023, 4:03 a.m. UTC | #1
Hey,

Pinging this since it's been up a month.

Upon further investigation into the usage of supported-systems, I don't 
think the 4th patch is correct and it can therefore be disregarded.

Thanks,
Juli
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 2c87976721..1611b9f0a6 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4042,7 +4042,13 @@  (define-public uwufetch
 well as a summary of system information.  UwUFetch's unique contribution is the
 uwu-ification of various words used in the description.  For example, Guix
 becomes gUwUix.")
-    (license license:gpl3+)))
+    (license license:gpl3+)
+    (supported-systems
+     (filter (lambda (sys)
+               (not (member sys (list "i586-gnu"
+                                      "mips64el-linux"
+                                      "powerpc-linux"))))
+             %supported-systems))))
 
 (define-public screenfetch
   (package