diff mbox series

[bug#64305,3/4] gnu: uwufetch: Add missing propagated inputs.

Message ID 20230626171407.23641-3-juli@incana.org
State New
Headers show
Series Fixup uwufetch. | expand

Commit Message

Juliana Sims June 26, 2023, 5:14 p.m. UTC
* gnu/packages/admin.scm (uwufetch) [propagated-inputs]: Add missing
propagated inputs.
---
 gnu/packages/admin.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

Ludovic Courtès Aug. 8, 2023, 3:23 p.m. UTC | #1
Hi!

Finally applied patches #1 and #2, thanks!

Juliana Sims <juli@incana.org> skribis:

> * gnu/packages/admin.scm (uwufetch) [propagated-inputs]: Add missing
> propagated inputs.

[...]

> +    (propagated-inputs (list gawk
> +                             grep))

This is somewhat intrusive as installing uwufetch would now pull in
these two packages in the user’s profile.

Could we address the problem differently, for instance by changing a
mere reference to “gawk” to “/gnu/store/…/bin/gawk” in the source?

TIA,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 0af0ef4051..2c87976721 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4029,6 +4029,8 @@  (define-public uwufetch
           (add-before 'install 'make-include-dir
             (lambda _
               (mkdir-p (string-append #$output "/include")))))))
+    (propagated-inputs (list gawk
+                             grep))
     (inputs (list lshw
                   ;; viu XXX not yet packaged in Guix
                   xwininfo))