diff mbox series

[bug#63183] gnu: Add emacs-next-pgtk-xwidgets.

Message ID 20230430040206.30101-1-antero@mailbox.org
State New
Headers show
Series [bug#63183] gnu: Add emacs-next-pgtk-xwidgets. | expand

Commit Message

Antero Mejr April 30, 2023, 4:02 a.m. UTC
* gnu/packages/emacs.scm (emacs-next-pgtk-xwidgets): New variable.
---
 gnu/packages/emacs.scm | 13 +++++++++++++
 1 file changed, 13 insertions(+)

Comments

Liliana Marie Prikler May 7, 2023, 4 p.m. UTC | #1
Am Sonntag, dem 30.04.2023 um 04:02 +0000 schrieb Antero Mejr:
> * gnu/packages/emacs.scm (emacs-next-pgtk-xwidgets): New variable.
> ---
Pushed

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 8da7279147..c29ce1b567 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -461,6 +461,19 @@  (define-public emacs-next-pgtk
     (description "This Emacs build implements graphical UI purely in terms
 of GTK and supports tree-sitter.")))
 
+(define-public emacs-next-pgtk-xwidgets
+  (package
+    (inherit emacs-next-pgtk)
+    (name "emacs-next-pgtk-xwidgets")
+    (synopsis "Emacs text editor with @code{xwidgets} and @code{pgtk} support")
+    (arguments
+     (substitute-keyword-arguments (package-arguments emacs-next-pgtk)
+       ((#:configure-flags flags #~'())
+        #~(cons "--with-xwidgets" #$flags))))
+    (inputs
+     (modify-inputs (package-inputs emacs-next-pgtk)
+       (prepend gsettings-desktop-schemas webkitgtk-with-libsoup2)))))
+
 (define-public emacs-minimal
   ;; This is the version that you should use as an input to packages that just
   ;; need to byte-compile .el files.