diff mbox series

[bug#63136,12/14] gnu: python-pytest-arraydiff: Update to 0.5.0.

Message ID 20230427234313.19013-12-sharlatanus@gmail.com
State New
Headers show
Series : python-astropy: Update to 5.2.2, fix build. | expand

Commit Message

Sharlatan Hellseher April 27, 2023, 11:43 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-arraydiff): Update to
0.5.0.
[native-inputs]: Add python-setuptools-scm.
[propagated-inputs]: Remove python-six.
---
 gnu/packages/python-check.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 71bbf59d49..9a61f59d56 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -541,22 +541,22 @@  (define-public python-pytest-astropy
 (define-public python-pytest-arraydiff
   (package
     (name "python-pytest-arraydiff")
-    (version "0.3")
+    (version "0.5.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pytest-arraydiff" version))
        (sha256
-        (base32 "05bcvhh2ycxa35znl8b3l9vkcmx7vwm5c3fpakbpw46c7vsn4bfy"))))
+        (base32 "1livzfbi7ag17hskd5845dh1kdir24f7jrbw8y2s1pyhzyz4jhbi"))))
     (build-system python-build-system)
     (arguments
      ;; Tests require python-astropy, which itself requires this package.
      ;; Disable tests to avoid the circular dependency problem.
      '(#:tests? #f))
     (native-inputs
-     (list python-pytest)) ; for sanity-check
+     (list python-pytest python-setuptools-scm)) ; for sanity-check
     (propagated-inputs
-     (list python-numpy python-six))
+     (list python-numpy))
     (home-page "https://github.com/astropy/pytest-arraydiff")
     (synopsis "Pytest plugin to help with comparing array output from tests")
     (description