mbox series

[bug#63136,00/14] : python-astropy: Update to 5.2.2, fix build.

Message ID 20230427234102.18801-1-sharlatanus@gmail.com
Headers show
Series : python-astropy: Update to 5.2.2, fix build. | expand

Message

Sharlatan Hellseher April 27, 2023, 11:41 p.m. UTC
Hi Guix!

Here is the first portion of patches fixing failed to build graph of some
astronomical software where python-astropy plays important role. I tried to
bump to the latest buildable version and clean up packages where possible.

Package h3 needs some extra attention to check the license (it is Uber's
project with Apache-2 license as seen on front page).

h3 comes as C library with few language bindings, maybe, rest of them would be
included to Guix :) but for now it's only python-h3 and lower version
python-h3-3 to build python-timezonefinder.

> guix build --rounds=2 python-pytest-doctestplus python-pytest-filter-subpackage python-pytest-astropy python-extension-helpers python-jplephem python-skyfield python-pytest-remotedata python-pytest-arraydiff python-pytest-mpl python-astropy
> /gnu/store/1rgqf2szj1lsxpblb2wcb6hj1vykbpaf-python-astropy-5.2.2
> /gnu/store/xrkmzpaazaydhfchrl9dii522fsd4qir-python-pytest-mpl-0.16.1
> /gnu/store/4kx2im5j5pgydmhfflqzbipqwf2vx1xq-python-pytest-arraydiff-0.5.0
> /gnu/store/gr3sqfqyck4mmvqx735c8qrj3bhy7ni7-python-pytest-remotedata-0.4.0
> /gnu/store/fdp92xqqkiv4pggfsycxpkbz5pwk8g8p-python-skyfield-1.46
> /gnu/store/8j6hkls1jnadcnbn7nc4qjw3jd1wzhyc-python-jplephem-2.18
> /gnu/store/f43gcwsh51qnzx87gwm2xlrhry925nrm-python-extension-helpers-1.0.0
> /gnu/store/jqq065pc1g8z1822crpk8854pwi194hj-python-pytest-astropy-0.10.0
> /gnu/store/b3bpzjzklx0xklp10xnwscia7c7hx1pj-python-pytest-filter-subpackage-0.1.2
> /gnu/store/rwzqivchng64qwv4r5v29khn10bs53qz-python-pytest-doctestplus-0.12.1

Astropy has a lot of tests and 97.207% passed!
> = 23768 passed, 420 skipped, 139 deselected, 124 xfailed in 281.98s (0:04:41) ==
> phase `check' succeeded after 287.3 seconds
> starting phase `sanity-check'
> validating 'astropy' /gnu/store/1rgqf2szj1lsxpblb2wcb6hj1vykbpaf-python-astropy-5.2.2/lib/python3.10/site-packages
> ...checking requirements: OK
> ...trying to load module astropy: OK
> ...trying to load endpoint console_scripts fits2bitmap: OK
> ...trying to load endpoint console_scripts fitscheck: OK
> ...trying to load endpoint console_scripts fitsdiff: OK
> ...trying to load endpoint console_scripts fitsheader: OK
> ...trying to load endpoint console_scripts fitsinfo: OK
> ...trying to load endpoint console_scripts samp_hub: OK
> ...trying to load endpoint console_scripts showtable: OK
> ...trying to load endpoint console_scripts volint: OK
> ...trying to load endpoint console_scripts wcslint: OK

I could not list dependent packages due to internal faileur:
> ./pre-inst-env guix refresh python-astropy -l
> Backtrace:
> In ice-9/boot-9.scm:
>   1752:10 16 (with-exception-handler _ _ #:unwind? _ # _)
> In unknown file:
>           15 (apply-smob/0 #<thunk 7f1409d012e0>)
> In ice-9/boot-9.scm:
>     724:2 14 (call-with-prompt _ _ #<procedure default-prompt-handle…>)
> In ice-9/eval.scm:
>     619:8 13 (_ #(#(#<directory (guile-user) 7f1409d06c80>)))
> In guix/ui.scm:
>    2300:7 12 (run-guix . _)
>   2263:10 11 (run-guix-command _ . _)
> In ice-9/boot-9.scm:
>   1752:10 10 (with-exception-handler _ _ #:unwind? _ # _)
>   1752:10  9 (with-exception-handler _ _ #:unwind? _ # _)
> In guix/store.scm:
>    659:37  8 (thunk)
>   2168:25  7 (run-with-store #<store-connection 256.99 7f1409c26410> …)
> In guix/scripts/refresh.scm:
>    494:47  6 (_ _)
> In guix/packages.scm:
>   1405:32  5 (package-closure _ #:system _)
>   1592:16  4 (package->bag _ _ _ #:graft? _)
>   1693:48  3 (thunk)
> In gnu/packages/polkit.scm:
>    165:22  2 (inputs #<package xfce4-session@4.18.2 gnu/packages/xfc…>)
> In ice-9/boot-9.scm:
>   1685:16  1 (raise-exception _ #:continuable? _)
>   1685:16  0 (raise-exception _ #:continuable? _)
> 
> ice-9/boot-9.scm:1685:16: In procedure raise-exception:
> error: polkit-for-system: unbound variable

Thanks!

Sharlatan Hellseher (14):
  gnu: python-pytest-doctestplus: Update to 0.12.1.
  gnu: Add h3.
  gnu: Sort use-module alphabetically in (gnu packages geo).
  gnu: Add python-h3.
  gnu: Add python-timezonefinder.
  gnu: pytest-filter-subpackage: Update to 0.1.2.
  gnu: python-pytest-astropy: Simplify package.
  gnu: python-extension-helpers: Update to 1.0.0.
  gnu: python-jplephem: Update to 2.18.
  gnu: python-skyfield: Update to 1.46.
  gnu: python-pytest-remotedata: Update to 0.4.0.
  gnu: python-pytest-arraydiff: Update to 0.5.0.
  gnu: python-pytest-mpl: Update to 0.16.1.
  gnu: python-astropy: Update to 5.2.2, fix build.

 gnu/packages/astronomy.scm    |  29 +++++---
 gnu/packages/geo.scm          | 127 ++++++++++++++++++++++++++++++++--
 gnu/packages/python-check.scm | 116 ++++++++++++-------------------
 gnu/packages/python-xyz.scm   |  25 ++++---
 gnu/packages/time.scm         |  37 ++++++++++
 5 files changed, 238 insertions(+), 96 deletions(-)


base-commit: b8b3af93da5340eecab77fa7b12c7ce364bf11cf

Comments

Sharlatan Hellseher May 2, 2023, 2:51 p.m. UTC | #1
Hi,

A gentle ping for review. Please let me know if I need to update patch set.

Regards,
Oleg
Efraim Flashner May 8, 2023, 9:52 a.m. UTC | #2
On Tue, May 02, 2023 at 03:51:28PM +0100, Sharlatan Hellseher wrote:
> Hi,
> 
> A gentle ping for review. Please let me know if I need to update patch set.
> 
> Regards,
> Oleg

Everything looks good. I've gone ahead and pushed the patches.