diff mbox series

[bug#62989] gnu: Add python-rseqc.

Message ID 20230421102845.46529-1-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#62989] gnu: Add python-rseqc. | expand

Commit Message

nafkhamdc April 21, 2023, 10:28 a.m. UTC
* gnu/packages/bioinformatics.scm (python-rseqc): New variable.
---
 gnu/packages/bioinformatics.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Ricardo Wurmus Aug. 5, 2023, 9:27 p.m. UTC | #1
I’m closing this because

1. we have a package for rseqc.
2. this is an unmaintained fork
3. IIRC it doesn’t actually work
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b27e12a5b4..ecc1815539 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3060,6 +3060,30 @@  (define-public python-pysam
 also includes an interface for tabix.")
     (license license:expat)))
 
+(define-public python-rseqc
+  (package
+    (name "python-rseqc")
+    (version "5.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "RSeQC" version))
+              (sha256
+               (base32
+                "106av4ms6agrfjdlw5j3fsrk86clr0f4ygysv19g66l6hj3laz9w"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-bx-python python-numpy python-pybigwig
+                             python-pysam))
+    (native-inputs (list python-cython python-nose))
+    (home-page "https://github.com/MonashBioinformaticsPlatform/RSeQC")
+    (synopsis "RNA-seq quality control packag")
+    (description
+     "Useful modules that can comprehensively evaluate high throughput sequence data.
+Some basic modules quickly inspect sequence, quality, nucleotide composition bias,
+PCR bias and GC bias, while RNA-seq specific modules evaluate sequencing saturation,
+mapped reads distribution, coverage uniformity, strand specificity, transcript level
+RNA integrity and etc.")
+    (license license:gpl3)))
+
 (define-public python-twobitreader
   (package
     (name "python-twobitreader")