@@ -354,6 +354,47 @@ (define-public python-django-taggit
application for simple tagging.")
(license license:bsd-3)))
+(define-public python-django-treebeard
+ (package
+ (name "python-django-treebeard")
+ (version "4.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "django-treebeard" version))
+ (sha256
+ (base32 "1nk9b40cp0jsxr3qsb16mh9xr0z3cvf69yp5ahh70fajf8bh05c0"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (lambda _
+ (setenv "PYTHONPATH"
+ (string-append ".:" (getenv "GUIX_PYTHONPATH")))
+ (setenv "DJANGO_SETTINGS_MODULE" "treebeard.tests.settings")
+ (substitute* "setup.py" ((".*pythonpath.*") ""))
+ (invoke "pytest" "-vv"))
+ (format #t "test suite not run~%")))))))
+ (propagated-inputs (list python-django
+ python-sqlparse))
+ (native-inputs (list python-wheel
+ python-pytest-django))
+ (home-page "https://github.com/django-treebeard/django-treebeard/")
+ (synopsis "Efficient tree implementations for Django")
+ (description
+ "This package provides @code{django-treebeard}, an efficient tree
+implementations for Django. It includes 3 different tree implementations
+with the same API:
+@itemize
+@item Adjacency List
+@item Materialized Path
+@item Nested Sets
+@end itemize")
+ (license license:bsd-3)))
+
(define-public python-easy-thumbnails
(package
(name "python-easy-thumbnails")