diff mbox series

[bug#55474,v3,02/17] gnu: python-django-filter: Update to 22.1.

Message ID 20230417145337.12403-2-ngraves@ngraves.fr
State New
Headers show
Series [bug#55474,v3,01/17] gnu: python-django-taggit: Update to 3.1.0. | expand

Commit Message

Nicolas Graves April 17, 2023, 2:53 p.m. UTC
* gnu/packages/django.scm (python-django-filter): Update to 22.1.
[synopsis] Simpler synopsis.
[description] More precise description.
---
 gnu/packages/django.scm | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 8972510018..365a7c1e58 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -472,13 +472,13 @@  (define-public python-django-haystack
 (define-public python-django-filter
   (package
     (name "python-django-filter")
-    (version "2.3.0")
+    (version "22.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "django-filter" version))
               (sha256
                (base32
-                "1bz5qzdk9pk4a2lp2yacrdnqmkv24vxnz4k3lykrnpc3b7bkvrhi"))))
+                "19abb7ikcjxfwggjh0bx40sx2dpv7q60bchva6r86zjgx1v3nizd"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -490,12 +490,12 @@  (define-public python-django-filter
      (list python-django python-django-rest-framework
            python-django-crispy-forms python-mock))
     (home-page "https://django-filter.readthedocs.io/en/latest/")
-    (synopsis "Reusable Django application to filter querysets dynamically")
+    (synopsis "Django application filtering querysets dynamically")
     (description
-     "Django-filter is a generic, reusable application to alleviate writing
-some of the more mundane bits of view code.  Specifically, it allows users to
-filter down a queryset based on a model’s fields, displaying the form to let
-them do this.")
+     "This package provides @code{django-filter}, a generic and
+reusable application to alleviate writing some of the more mundane bits of
+view code.  Specifically, it allows users to filter down a queryset based on a
+model’s fields, displaying the form to let them do this.")
     (license license:bsd-3)))
 
 (define-public python-django-allauth