diff mbox series

[bug#62771,3/9] gnu: serd: Update to 0.30.16.

Message ID 20230411080955.22584-2-mail@brendan.scot
State New
Headers show
Series Add Easyeffects | expand

Commit Message

Brendan Tildesley April 11, 2023, 8:09 a.m. UTC
From: Brendan Tildesley <mail@brendan.scot>

* gnu/packages/rdf.scm (serd): Update to 0.30.16.
[build-system]: Use meson.
[arguments]: Remove.ldflag hack not needed with meson.
---
 gnu/packages/rdf.scm | 23 ++++++++---------------
 1 file changed, 8 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 13e62baa84..c62bcd4380 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
 ;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Brendan Tildesley <mail@brendan.scot>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -33,6 +34,7 @@  (define-module (gnu packages rdf)
   #:use-module (guix download)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system meson)
   #:use-module (guix build-system python)
   #:use-module (guix build-system waf)
   #:use-module (gnu packages)
@@ -278,27 +280,18 @@  (define-public redland
 (define-public serd
   (package
     (name "serd")
-    (version "0.30.8")
+    (version "0.30.16")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.drobilla.net/serd-"
-                                 version ".tar.bz2"))
+                                 version ".tar.xz"))
              (sha256
               (base32
-               "11zs53yx40mv62vxsl15mvdh7s17y5v6lgcgahdvzxgnan7w8bk7"))))
-    (build-system waf-build-system)
+               "0ilimkczibiwwvc12i14b8zi6ng42hjf9j907g8dik8rlmnlh3zm"))))
+    (build-system meson-build-system)
     (arguments
-     `(#:tests? #f                      ; no check target
-       #:phases
-       (modify-phases %standard-phases
-         (add-before
-          'configure 'set-ldflags
-          (lambda* (#:key outputs #:allow-other-keys)
-            (setenv "LDFLAGS"
-                    (string-append "-Wl,-rpath="
-                                   (assoc-ref outputs "out") "/lib"))
-            #t)))))
-    (home-page "https://drobilla.net/software/serd/")
+     `(#:tests? #f)) ; Tests fail due to "file not found" even though it exists??
+    (home-page "https://drobilla.net/software/serd.html")
     (synopsis "Library for RDF syntax supporting Turtle and NTriples")
     (description
      "Serd is a lightweight C library for RDF syntax which supports reading