[bug#42682,v2,3/9] gnu: Add python-spinners.
Commit Message
* gnu/packages/python-xyz.scm (python-spinners): New variable.
---
gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
@@ -15476,6 +15476,36 @@ (define-public python-progressbar33
;; Either or both of these licenses may be selected.
(license (list license:lgpl2.1+ license:bsd-3))))
+(define-public python-spinners
+ (package
+ (name "python-spinners")
+ (version "0.0.24")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "spinners" version))
+ (sha256
+ (base32
+ "0zz2z6dpdjdq5z8m8w8dfi8by0ih1zrdq0caxm1anwhxg2saxdhy"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-test-requirements
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("requirements-dev.txt")
+ (("==") ">=")))))))
+ (native-inputs
+ (list python-nose
+ python-coverage
+ python-tox
+ python-pylint))
+ (home-page "https://github.com/manrajgrover/py-spinners")
+ (synopsis "Spinners for terminals")
+ (description "This package provides more than 60 spinners for terminals. Is a
+python port of the node library cli-spinners.")
+ (license license:expat)))
+
(define-public python-colorama
(package
(name "python-colorama")