diff mbox series

[bug#42682,v2,1/9] gnu: Add python-hjson.

Message ID 20230409043116.13244-2-plattfot@posteo.net
State New
Headers show
Series Add qmk-cli | expand

Commit Message

Fredrik Salomonsson April 9, 2023, 4:31 a.m. UTC
* gnu/packages/python-xyz.scm (python-hjson): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bd68d060b5..6ce8aa2072 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -135,6 +135,7 @@ 
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;; Copyright © 2023 Amade Nemes <nemesamade@gmail.com>
 ;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2023 Fredrik Salomonsson <plattfot@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2413,6 +2414,25 @@  (define-public python-humanfriendly
 helpers.")
     (license license:expat)))
 
+(define-public python-hjson
+  (package
+    (name "python-hjson")
+    (version "3.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "hjson" version))
+              (sha256
+               (base32
+                "0xfgrnwr6xaqfkaxnzd06sw8zv6dpkbrk0w0kjbag0yg4xd4gbsm"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:tests? #f)) ; no tests
+    (home-page "https://github.com/hjson/hjson-py")
+    (synopsis "Hjson, the Human JSON user interface")
+    (description "This package provides a configuration file format that caters
+to humans and helps reduce the errors they make.")
+    (license license:expat)))
+
 (define-public python-textparser
   (package
     (name "python-textparser")