diff mbox series

[bug#62622,5/8] gnu: python-rtree: Update to 1.0.1.

Message ID 20230402174551.159212-5-felgru@posteo.net
State New
Headers show
Series Update proj and a few other geo packages | expand

Commit Message

Felix Gruber April 2, 2023, 5:45 p.m. UTC
* gnu/packages/geo.scm (python-rtree): Update to 1.0.1.
  [build-system]: Use pyproject-build-system instead of
  python-build-system.
  [arguments]: Remove custom 'check phase.
---
 gnu/packages/geo.scm | 12 ++++--------
 1 file changed, 4 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 344ffae8fb..e046797a3f 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1655,14 +1655,14 @@  (define-public libspatialindex
 (define-public python-rtree
   (package
     (name "python-rtree")
-    (version "1.0.0")
+    (version "1.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Rtree" version))
        (sha256
-        (base32 "10lnhf67c9pb0yisxdqmb52dy6lj1za1h9d4p69v0ihk2a138j6h"))))
-    (build-system python-build-system)
+        (base32 "0aalh07fyf6vpr0a6zswnqvvrjhyic1zg6w4bl368fihkilj2892"))))
+    (build-system pyproject-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -1672,11 +1672,7 @@  (define-public python-rtree
                (substitute* "rtree/finder.py"
                  (("find_library\\(\"spatialindex_c\"\\)")
                   (string-append  "\"" libspatialindex
-                                  "/lib/libspatialindex_c.so\""))))))
-         (replace 'check
-           (lambda* (#:key outputs tests? #:allow-other-keys)
-             (when tests?
-                 (invoke "pytest")))))))
+                                  "/lib/libspatialindex_c.so\"")))))))))
     (native-inputs
      (list python-numpy python-pytest python-wheel))
     (inputs