diff mbox series

[bug#62622,4/8] gnu: python-cartopy: Update to 0.21.1.

Message ID 20230402174551.159212-4-felgru@posteo.net
State New
Headers show
Series Update proj and a few other geo packages | expand

Commit Message

Felix Gruber April 2, 2023, 5:45 p.m. UTC
* gnu/packages/geo.scm (python-cartopy): Update to 0.21.1.
---
 gnu/packages/geo.scm | 13 +++++++++++--
 1 file changed, 11 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8c93f86dd2..344ffae8fb 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1183,8 +1183,17 @@  (define-public python-cartopy
                (invoke "python" "-m" "pytest" "--pyargs" "cartopy"
                        ;; These tests require online data.
                        "-m" "not natural_earth and not network"
-                       ;; This one too but it's not marked as such.
-                       "-k" "not test_gridliner_labels_bbox_style")))))))
+                       "-k"
+                       (string-append
+                         ;; This one too but it's not marked as such.
+                         "not test_gridliner_labels_bbox_style"
+                         ;; Those tests fail with proj 9.2.0
+                         ;; https://github.com/SciTools/cartopy/issues/2145
+                         " and not test_epsg"
+                         " and not test_default"
+                         " and not test_eccentric_globe"
+                         " and not test_ellipsoid_transform"
+                         " and not test_eccentric_globe"))))))))
     (propagated-inputs
      (list python-matplotlib
            python-numpy